Support » Fixing WordPress » 4mb upload limit too small

  • I’m a musician, wanting to continue to use wordpress to upload my music in mp3 format. The recent 4mb limit for media uploads is REALLY restrictive. 10mb was workable, but 4mb is hopeless, limiting me to songs under about 4 mins (compressing it further loses quality). Can you please make it 20mb? Or at least 10…?


Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi


    Forum Moderator

    The upload limit is coming from your server – not WordPress. Try increasing all of the following in your server’s php.ini file:

    I’m trying to do the same, where do I find this on my directory? Is it hidden in a specific folder? Thanks

    First, find out if it is supported by your host – each host is different

    Next, if your host does support php.ini, find out where they tell you to put it

    On several hosts, I could put mine in my public root – html or public_html directory

    IT did not exist, so I had to create the file. Google and the help files of my particular host were a big help in proper php.ini syntax

    Ok thanks. I’m going to ask them first.

    Another question, if you can help.

    I tried to enter a youtube video in a video gallery, and it asks to change a setting “allow_url_fopen”, from OFF to ON, and now it gives me an error.

    Again, that is hosting territory – provide them with that info and see if they can help.

    Also – if you are uploading music, you may be better off learning how to use FTP, and making a music directory where you manually place all of your files.

    I host DJ mixes, which never reliably upload through WordPress or the browser. I just use FTP to upload my music, and manually link from my posts. Just something to consider – the bigger the files, the harder it is to upload through the browser – things get flaky.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘4mb upload limit too small’ is closed to new replies.