WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 406 Not Acceptable

[Resolved] 406 Not Acceptable

  • I have the 2.51 version and I get this message every time I try to edit and then re-save a post that I’ve already published.
    —————————————-
    Not Acceptable
    An appropriate representation of the requested resource /wp-admin/post.php could not be found on this server.

    Apache/1.3.41 Server at lostluvback.com Port 80
    —————————————–
    I didn’t have this issue with earlier versions of WordPress.

    Thanks,
    Max

Viewing 5 replies - 1 through 5 (of 5 total)
  • whooami

    @whooami

    Member

    Do I name the file .htaccess.php or just .htaccess?

    Also my error is about the post.php. Are all 406 errors the same even though in the other posts they say index.php and page.php ?

    whooami

    @whooami

    Member

    quoting myself:

    Rename the uploaded file to .htaccess (with the .)

    IF YOU DO HAVE an .htaccess in your wp-admin/ directory:

    most 406, if not nearly all 406 errors that occur when using WP are a result of mod_security

    It didn’t work so I looked back at older posts and found this code that addresses the “post.php” error.

    <IfModule mod_security.c>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    I put this code in the .htaccess file and it appears to be working. At least for now.
    Thanks

    whooami

    @whooami

    Member

    lol, youre welcome 🙂

    “it” did work, and im not sure what you mean by “it” not working. The entire point of my sending you back to those other posts was to get you to disable it. Thats exactly what you did, and it does work.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] 406 Not Acceptable’ is closed to new replies.