404 when i activate plugin (2 posts)

  1. hungryhippos
    Posted 3 years ago #

    I cannot figure out why i get the 404 when i activate the plugin. it says its missing plugins.php but it is on the web server. I have tried deleting and re-adding via ftp several times. I didnt have this problem when i activated it on my test site but on our production one it continues to give me a 404 with this in the url bar:


    I also tried to re save the permalink settings which was suggested in another forum with no luck. Plz help!


  2. Stefan Boonstra
    Plugin Author

    Posted 3 years ago #

    It could be that the slideshow is activating so slowly that there's server timeout. In this case it would probably help to disable the slideshow installation process. This runs at activation to make sure everyone's slideshows are preserved when updating.

    You can disable this process by going to the 'wp-content/plugins/slideshow-jquery-image-gallery/classes/' folder and opening the 'SlideshowPluginInstaller.php' file with a text editor. Then look for line 29 and 30. These lines look like this:

    if($currentVersion == null || self::firstVersionGreaterThanSecond(SlideshowPluginMain::$version, $currentVersion))

    Delete only those two lines, then save the file. After that, please try to activate the plugin again. Hopefully, it will activate successfully then.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Slideshow
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.