Support » Fixing WordPress » 404 when going to wp-admin/upload.php

  • Tried everything, so you are my “lender of last resort”: when I go to wp-admin/upload.php I get a 404. I have checked the server and the file is there. Also cleared everything and uploaded from fresh installation: nothing.

    Probably related: cannot upload images
    The uploaded file could not be moved to /wp-content/uploads
    Here I also tried everything (threw folder away and re-created it, changing CHMOD, altering .htaccess, changing settings etc). No result.

    Same when trying to create a Gallery in NgGallery.
    Unable to create directory wp-content/gallery/miscellaneous!
    Directory wp-content/gallery/miscellaneous is not writeable !
    Unable to create directory wp-content/gallery/miscellaneous/thumbs !

    Checked settings. It’s 777 alright.

    Who can help me out!

Viewing 8 replies - 1 through 8 (of 8 total)
  • Nobody?

    I got the same problem! Did you find a solution?

    i have same problem site is opening but when go to wp- admin then white screen appers

    I basically have the same problem with 404 on upload.php BUT ONLY when no files are uplaoded. One I upload some files no problems with 404.

    I think it will not help BUT …
    do you have a folder named blogs.dir in wp-content?
    if not, you can try to create it (when I delete it, my wordpress re-create it when I’m on the upload.php page)

    I am having the same issue, and it seems to be related to 3.0 and Windows IIS specifically. I have set up WordPress countless times on LAMP servers with next to no issue (save for the most common hangups), and this one finally has me stumped, even more so because I don’t have admin access to the server I’m running the setup on.

    In depth, my issue is this:

    I’m running WP on a Win server so there are no file permissions to be worried about, by default everyone has access to everything, which is so secure right?

    I have WordPress v3 installed and running… mostly. I cannot upload files when I create a page, it confirms the upload, shows me all the file details, but will never display the files, and when I browse to my uploads directory via FTP, the files aren’t there.

    When browsing to wp-admin/upload.php I get a 404 error, but the page is definitely there, and no other php file in that directory gives the same error.

    When I use the upload dialog when creating a page and browse over to my media library, the page 404s.

    I’m really stumped here, and even more so since I don’t normally work with windows and I don’t have admin access to the server (this is pro bono work for a public library in my area, so I have to ask the techies at the regional library that host the site to do all the tinkering).

    Thanks ahead of time for any help, and sorry about the wall of text.


    forunner, unfortunately it doesn’t help.

    This is the issues:

    1. Installing WP 3.0
    2. Go to wp-admin/upload.php –> gives an 404 error
    3. Go wp-admin/media-new.php and upload an image
    4. Go to wp-admin/upload.php –> it works

    5. delete permanently the only image that was uploaded
    6. Go to wp-admin/upload.php –> gives an 404 error

    So basically the 404 error occurs only when there are NO files in the media library at all!

    Also this error only occurs on IIS7.

    WP is working good on IIS6.

    This is quite strange error/bug.

    Ok, found information in the trac by ruslany:

    This is caused by a bug in IIS FastCGI that has been fixed in IIS 7 but hasn’t yet been fixed in IIS 7.5. Here is how to fix this:

    If this happens on IIS 7 then install this update:

    If this happens on IIS 7.5 (Windows 7 or Windows 2008 R2) then use the workaround described here: Note that this will be fixed in the SP1 of Windows 7 and Win2k8 R2.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘404 when going to wp-admin/upload.php’ is closed to new replies.