Support » Plugin: Imagify – Optimize your Images & Convert WebP » 404 undefined showing in Chrome console

  • Resolved torwoodgc

    (@torwoodgc)


    I spotted an issue when inspecting my pages with Chrome console

    https://ckps.org.uk/undefined

    This 404 error occurs only when the Imagify plugin is activated.
    I have tested with only Imagify running and get the 404. If I activate all my other plugins and deactivate Imagify then the error dissappears.

    I love the plugin, I’d just like to get rid of the error

    Thanks

    Kenny

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author WP Media

    (@wp_media)

    Hi Kenny,

    Thanks for your patience once again!

    This is related to using picture tag method for delivering WebP. The problem is an incompatibility issue with this feature and Divi theme. We are still not able to see what exactly is the problem here.

    We have created the GitHub issue here – https://github.com/wp-media/imagify-plugin/issues/496

    Since we changed our developer recently, we need some time to reorganize and I hope this will be one of the tasks we will tackle soon.

    Best Regards

    Hi,

    I have the exact same problem and I just subscribed to an Imagify plan: is there any progress on that matter since?

    Best regards,

    Plugin Author WP Media

    (@wp_media)

    Hi @stefanp44,

    We were still not able to work on this. I expect we will brainstorm this further on our end during this or the next week, so we will have more details about the time frame soon.

    Meanwhile, WebP display using picture tag should be turned off and you can use rewrite rules method (unless you use Cloudflare/CDN).

    Thanks for your patience!

    Best Regards,
    Marko

    HI @wp_media, I have the same issue and reported the bug to Ionna.

    I disabled webp because I dont use a cdn. Bummer because I bought credits of which 85% are still left in order to use webp. :/
    http://snap.ashampoo.com/3UZ7tWnJXBBwwKCxuMLS7rPft12dKA6GvXfJpsTHuv9LAceUOPIncYSvToY9OWgf

    @torwoodgc & @stefanp44
    Looks like we need a lot of patience because @ctjernqvist already reported this issue more then 10 months ago….
    https://wordpress.org/support/topic/undefined-added-to-urls/

    Hope that Imagify team will improve and start to work on the bug.

    Rank Math Seo 404 report tool showed me the issue. In general I also think this plugin is cool and wish bulk renaming functionality from image seo plugin would be integrated in the future.

    Thanks,
    Best

    Hi @wpschiemann

    Yes, I’ve seen the topic on these forums and the reported issue on github. You can still use webp though, following @wp_media advice: use rewrite rules instead of the picture method (you can still revert to picture later when the issue is fixed).

    Best

    Plugin Author WP Media

    (@wp_media)

    Hi everyone,

    Thanks for participating in this. We will speed up the process of investigating this problem and do our best to fix it soon.

    Best Regards
    Marko

    I am having the exact issue as well.

    Plugin Author WP Media

    (@wp_media)

    Hi @sifuhall,

    Thank you for letting us know!

    Unfortunately, this issue has still not been resolved. We are doing our best to investigate it, and we will update this forum topic as soon as we have news on this.

    For now, your available options are to switch to the “Use rewrite rules” option for displaying WebP (as long as you don’t use a CDN or Cloudflare) or to disable WebP display until a solution for this is reached.

    Best regards,

    Joseph

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘404 undefined showing in Chrome console’ is closed to new replies.