WordPress.org

Support

Support » How-To and Troubleshooting » 404 RSS Feeds…I’ve tried, really!

404 RSS Feeds…I’ve tried, really!

  • I just finished updating to 1.5. Everything is very nice except my RSS feeds have stopped working. (I’ve tried to do due dilligence before posting; apologies if I’ve missed the obvious).

    I 1.2.2 we had permalinks of this form:
    http://www.bobbytisdale.com/diary/index.php/archives/2005/02/08/february-8-2005/

    and the 1.5 Permalinks Options page still concurs showing this structure:

    /index.php/archives/%year%/%monthnum%/%day%/%postname%/

    The WordPress root directory is http://www.bobbytidale.com/diary

    The 404 page for our site returns to http://www.bobbytisdale.com (thus the redirect there when the

    rss link is clicked and fails). Aggregators such as NewsGator return 404 for both rss2 and comments feeds.

    It’s interesting to me that hitting http://www.bobbytisdale.com/diary/wp-rss.php returns some legit XML. But /wp-rss2.php results in a 404. Not sure why…

    I’ve searched the support forums for ‘Permalinks’ and for ‘.htaccess’ and tried various suggestions listed. I’ve also reviewed the .htaccess tips here: http://codex.wordpress.org/Using_Permalinks

    Following those tips, I tried:
    1. An empty .htaccess (1.5 should update it) w/ 666 access — \Pressing “Update Permalinks” leaves both files blank w/o any complaints from WordPress.

    2. Put the below .htaccess back w/ 666 access and trimmed trailing whitespace — no change

    3. Updated vars.php to set $is_apache = 1 since we are running on Apache.

    4. Tried .htaccess w/ “Options FollowSymLinks” as suggested in forums — no change.

    5. Tried changing back to default Kubrick theme – the same errors occur there.

    I noticed this bug report: http://mosquito.wordpress.org/view.php?id=903 But our server is Apache, not IIS so it didn’t seem to apply.

    Any suggestions?
    John

    (Here’s the .htaccess which I’m attempting to use — greek to me!)
    RewriteEngine On
    RewriteBase /diary/
    RewriteRule ^index.php/archives/category/(.*)/(feed|rdf|rss|rss2|atom)/?$ /diary/wp-feed.php?category_name=$1&feed=$2 [QSA]
    RewriteRule ^index.php/archives/category/?(.*) /diary/index.php?category_name=$1 [QSA]
    RewriteRule ^index.php/archives/author/(.*)/(feed|rdf|rss|rss2|atom)/?$ /diary/wp-feed.php?author_name=$1&feed=$2 [QSA]
    RewriteRule ^index.php/archives/author/?(.*) /diary/index.php?author_name=$1 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})?/?([0-9]{1,2})?/?([0-9]{1,2})?/?([_0-9a-z-]+)?/?([0-9]+)?/?$ /diary/index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/(feed|rdf|rss|rss2|atom)/?$ /diary/wp-feed.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
    RewriteRule ^index.php/archives/?([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([_0-9a-z-]+)/trackback/?$ /diary/wp-trackback.php?year=$1&monthnum=$2&day=$3&name=$4 [QSA]
    RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /diary/wp-feed.php?feed=$1 [QSA]
    RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /diary/wp-feed.php?feed=$1&withcomments=1 [QSA]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Spelling correction to the root url:

    The WordPress root directory is http://www.bobbytisdale.com/diary

    James Huff
    Support Team Rep.

    @macmanx

    Go here: http://cvs.sourceforge.net/viewcvs.py/cafelog/wordpress/wp-blog-header.php?rev=1.131&view=auto and click the “download” link. This will give you a new wp-blog-header.php file. Replace your wp-blog-header.php file with this new copy.

    Thanks for that macmanx. I edited wp-blog-header.php and FTP’d the new version over the old. Unfortunately, I am still getting 404 for the feeds.

    Are there any interesting debug commands I can insert to see where/why it’s not happy?

    Another trial:

    – I put a die(“at the top”); at the top of wp-blog-header.php and see that msg when the site renders.

    When I try http://www.bobbytisdale.com/diary/index.php/feed/
    however, it immediately gets a 404 (no custom message).

    This makes me think it’s a server config. issue but I’m still a relative php/apache novice — any thoughts?

    James Huff
    Support Team Rep.

    @macmanx

    My apologies, you are using permalinks which make use of the /index.php/ work-around. A /feed/ permlink using this work around will not function, despite the link being changed. What you will have to do is open footer.php and change:
    <a href="<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>

    to

    <a href="http://www.bobbytisdale.com/diary/wp-rss2.php">Entries (RSS)</a>

    and

    <a href="<?php bloginfo('comments_rss2_url'); ?>">Comments (RSS)</a>

    to

    <a href="http://www.bobbytisdale.com/diary/wp-commentsrss2.php">Comments (RSS)</a>

    Sorry about that minor mix-up.

    Excellent! I’m back on-line.

    Thanks for the wonderful support…I feel a donation coming on!

    John

    I’m having the same problem; 404 errors on people hitting http://www.mydomain.com/wp-rss2.php. I’m using normal permalinks, have the latest WP and went through all the same due diligence as above. Ideas?

    If you don’t want to use the permalink but a direct link, then the file is in your wordpress directory (not the root directory). Add “wordpress/” to your link above.

    Or use the permalink:
    http://www.automatorworld.com/feed

    Well, the problem is I’m not linking to it them manually; these are people using bots/newsreaders or what have you that automatically search a site for feeds. So I suppose some form of htaccess redirect is in order?

    Edit: Duh, yeah. Fixorated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘404 RSS Feeds…I’ve tried, really!’ is closed to new replies.