WordPress.org

Support

Support » How-To and Troubleshooting » 404 pages not working

404 pages not working

  • I just upgraded to the latest version 2.1.3, and found that the 404 page is no longer working. any time I put in an invalid page, it’s instead redirecting back to the front page. I thought it may have been something I put in the theme customization on my 404 template page, so I switched themes, but it still makes no difference, and all invalid links get redirected to the main page. Anyone run across this problem? Anyone have any solutions?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Anyone have any ideas? I’m still having this problem. What could cause my 404 page to stop working? it’s simply redirecting all incorrect pages to my main index.

    Did anyone figure this problem out? I think my problem with my 404 page is when I type a non existant page – it just sends me to a regular 404 page and not the one I made for my wordpress theme. Please Help! I can’t seem to figure thiw one out.

    If you’re using a page other than “index.php” as your main page this will give you a problem.

    In other words… if, in Options > Reading you have your “Front page displays:” option set to “a static page” then your 404 page won’t work correctly.

    The easy fix for this is to make your “index.php” file your 404 page.

    Thanks for the answer to this…I hope this is a bug that will be fixed soon, as it’s a pretty major thing to just be left to the forum for people to read and figure out on their own.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘404 pages not working’ is closed to new replies.