WordPress.org

Support

Support » Plugins and Hacks » [Resolved] 404 page, on submit

[Resolved] 404 page, on submit

  • I’m using FSCF v. 4.0.15.

    I get taken to a “404 Not Found” page when my form is submitted, otherwise the form works as it should. I use the redirect feature and after 3 seconds I am redirected. The submitted form is also delivered to my Inbox.

    HERE IS THE 404 PAGE
    Error 404 – Page not found!
    The page you are trying to reach does not exist, or has been moved. Please use the menus or the search box to find what you are looking for.

    I have tried to troubleshoot the problem, unsuccessfully, by…
    – disabled all other plugins
    – switched to the default theme
    – disabled redirect
    – deactivate/activated FSCF plugin

    I’ve also added some code to my themes’ function.php code to integrate another FSCF with paypal. That form seems to work fine. I removed the code from functions.php, but that did not solve the issue either.

    HERE IS THAT CODE

    function my_action_url_ssl($form_action_url, $form_id_num) {
    ##################################
     // control which forms you want this on
     $all_forms = false; // set to true for process on all forms, or false to use settings below
     $forms = array('2');  // one or more individual forms
     ##################################
     if ( !in_array($form_id_num, $forms) && $all_forms != true)
     return $form_action_url;
      // force form action URL to be SSL
    $form_action_url = 'https://www.paypal.com/cgi-bin/webscr';
       return $form_action_url;
    }
    //filter hook for form action URL
    add_filter('si_contact_form_action_url', 'my_action_url_ssl', 1, 2);

    http://wordpress.org/plugins/si-contact-form/

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author Mike Challis

    @mikechallis

    Compare the URL the form is on to the URL it redirects to
    Is it the same page?
    Is it the page you have set in redirect settings on the advanced tab?
    Are you trying to make it redirect to a different page than the one it lands on?

    This is just a guess…
    Maybe your site has a problem in the rewrite rules in the wordpress .htaccess

    The form is on http://iacreation.niftywebdesigns.com/contact/

    On submit it goes to http://iacreation.niftywebdesigns.com/contact/#FSContact1

    The redirect url is http://iacreation.niftywebdesigns.com

    I just tried renaming my htaccess file and re-ssaving Permalinks. That did not work.

    Plugin Author Mike Challis

    @mikechallis

    I want to help figure this out.

    All those links give this note:

    Sorry for the inconvenience.
    Our website is currently undergoing scheduled maintenance.
    Please try back in 60 days
    Thank you for your understanding.
    Admin-Login

    Hi Mike,

    Sorry about that. I thought I took it out of Maintenance Mode. IThey’ll work for you now.

    Thank You

    Plugin Author Mike Challis

    @mikechallis

    Try redirect URL set to
    http://iacreation.niftywebdesigns.com/index.php

    or make a thank you page (with a custom thank you message)and have it go there.
    http://iacreation.niftywebdesigns.com/thanks
    just hide the page from the menu on the site

    does that work?

    Also I see you have default labels, but you should check the box “Default as placeholder” in each field details to make the labels in the fields automatically blank out when you type there.

    Thanks Mike.

    The first suggestion that I followed was to check the box “Default as placeholder”, and it solved the problem. (I removed the “Label CSS” that I used. I’m not sure if that was contributing to my issue though.)

    I’m having the same issue, url that’s getting the 404 is the same as the url of the page the form is on, I’ve copied it from the url bar b4 it redirects and it’s fine, displays the newsletter, but on submit, it gives me the 404. (I previously removed the #jumplink to the form itself) You see the 404 for 3 seconds b4 it redirects to the home page. I’m using an automattic theme, toolbox, testing on a dev site, I haven’t done anything weird in htaccess or redirect settings.

    Plugin Author Mike Challis

    @mikechallis

    Check these possible causes and let me know what you find

    The theme you are using could be causing it
    Do this as a test:
    In Admin, click on Appearance, Themes.
    Temporarily activate your theme to a WP default one…
    “Twenty Thirteen” (default for WP 3.6, 3.7)

    It does not cause any harm to your WP to temporarily change the theme, test if the errors went away, and then and change the theme back.
    Does it work properly with a default WP theme?
    If it does, then the theme you are using is the cause. Use a different theme or report the errors to the theme developer.

    Maybe another plugin is conflicting
    Look on the Admin – Plugins – menu.
    Temporarily Disable (not uninstall) all your other plugins.
    Did the problem you were having go away? If yes, Activate each of the plugins, one by one, to determine which one conflicts. Test if the problem goes away after activating each plugin one at a time. This way you can determine which plugin was causing the problem. Once you determine a plugin is conflicting, check the plugin version to be sure it is compatible with your version of WP. Sometimes plugins are no longer updated, then new WP versions come out and the plugin will generate errors or no longer function as intended. Report any problems you find to the plugin author.

    Hi Mike,
    It’s the toolbox theme, which has been extensively customized. I guess I’ll turn on the debugger and see if I get any info there. It’s pretty frustrating, because the url it’s showing is the same as the newsletter url, which should work. I may try creating a thank you page and redirecting to that without a delay, to see if that works.
    Thanks for your quick reply!
    Wendy

    I didn’t find any errors on debug, but I wanted to let others know that the solution of creating a thank you page and redirecting to it worked. I like that functionality, so, going with that.

    Actually, that wasn’t a solution because the “page not found” error happened on the captcha as well. After scrutinizing my theme, I figured out that I had a custom post type named “city” and a form field named “city” and that was causing the problem. I had read the posts about wordpress reserved names, but hadn’t thought about custom post types. Just thought I’d add in case anyone else has the same problem, it could save some time! I just renamed the field tag and it was resolved.

    ERROR: si-contact-form.php plugin says GD image support not detected in PHP!

    I get this error after the latest version of FS-Contact-Form is installed?

    I tried that and got another error message

    ‘sudo: apt-get: command not found’

    Plugin Author Mike Challis

    @mikechallis

    csites2g, please start your own thread. You posted in a totally different topic. The problem you have can be resolved by your web host support.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Resolved] 404 page, on submit’ is closed to new replies.