Support » Fixing WordPress » 404 page not showing

  • Hello,

    My 404.php page isn’t getting pulled into action when someone visits http://www.davidairey.com/404.

    I’ve created a custom 404 page and it’s located in my theme folder, saved as 404.php – I’ve no idea why it’s not working:

    /www/www/wp-content/themes/airey

    Can you please help?

Viewing 10 replies - 1 through 10 (of 10 total)
  • David and anyone else…my problem is that no 404 is working at all (either a custom one or the server default). Something is wrong with my wordpress code so that when a page that doesn’t exist is navigated it returns the entire site content. This is really bad and I must figure out how to fix it. I’ve done extensive research online and can’t figure it out. I first became aware of the situation when google webmaster tools told me that my header “returns a 200 success instead of a 404”.

    Please help!
    Thanks in advance,
    Scarlett

    Having exactly the same problem at the moment with a v 2.5.1 site – if anyone has a solution it would be enormously appreciated…

    I found a couple of other threads that suggested the problem may be to do with having a static page set as the homepage (which is the case here). A couple of people suggested selecting a static posts page as well, but that doesn’t seem to help – 404 errors now resolve to a completely blank page.

    Any resolution to this? I’m getting the same (entire site within what should be the 404 page). Same here with the static front page.

    I just upgraded to a new host and wp 2.5.1 and have the same problem. Users who navigate to nonexistent pages see a concatenation of most of my blogs pages! The 404 page isn’t working at all. Any idea how to fix this?

    I found the fix in another post. Apparently this is a bug in WP 2.5 and 2.5.1 that appears when your home page is a “page” rather than the normal WordPress blog homepage.

    The fix is described here:
    http://www.heritage-tech.net/797/improper-404-error-handling-fix-for-wordpress-25/

    and here:
    http://trac.wordpress.org/attachment/ticket/6539/query-404.diff

    This should be a sticky.

    Mellco

    PERFECT!
    All is well. Thanks.

    nice one dude

    When i fixed this…my wp-admin page was not found. So when I typed in http://www.mysite.com/wp-admin to access my dashboard…it went to my 404 page. I changed it back to a singe = sign…and now I can access my dashboard again. Has anyone else had this problem?

    I had this problem, and it did appear to be caused by setting a static front page. Setting a specific posts page as well fixed it.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘404 page not showing’ is closed to new replies.