Support » Fixing WordPress » 404 page not found when saving/updating a posts/page

  • Hi guys,

    I know this is an existing issue to others but i could not find a true solution to this issue

    I have try the plugin being activated/deactivated one by one. But still to no success.

    Could someone help me with this issue. Thanks

    btw,
    htaccess also iclude the correct set up

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    <IfModule mod_security.c>
    SecFilterEngine Off
    </IfModule>

Viewing 12 replies - 1 through 12 (of 12 total)
  • I too just started experiencing this. I noticed it only happens if I have html-like character in the post/page. Things like < or & cause the issue. Removing that, and it will save/preview/etc like it should.

    Are you seeing that too?

    Having similar issue. Everything seems right from htaccess point and i even tried deactivating all plugin. But I still have this issue. Memory limit is 384M which is ok for WP.

    I also face this issue today. Even the preview button took me to “Page Not Found”. Same like @ncpenn, the problem only occurs when I input html-like character. Is there something wrong with WordPress?

    hi…I tried to add a picture and update my page…it returns a 404 error…

    Yes the issue same to like what @ncpenn and @lilpanda said

    When i update a post whith no html chracters it was ok

    Hopefully someone could tell us if why this is happening now.

    Thanks

    Pretty much all of us facing this issue. No 404 error in normal post but a post with hyperlink or image return 404. I tried deactivating all plugin and using default theme but no luck.
    Even repaired + optimized the database.

    I am experiencing the same issues with saving draft or previewing it. It automatically goes to 404 page.
    I was able to make changes as and when the day before, but with the current issue, it’s certainly distressing not knowing what went wrong.
    I know the page is still there when you click to preview it in the ‘All Pages’ page, and it looks just fine.
    I have cleared my cookies, logged in and out, but to no avail. As I’m using wordpress on the net, debugging it, is something I’m not familiar with.

    Hope this issue gets resolved 🙁

    Yes the issue same to like what @ncpenn and @lilpanda said

    Hopefully someone could tell us if why this is happening now.

    Thanks

    May be problem by the editor

    if u want to try without bold, underline the page and update me also

    I’m resolved (but I’m not the OP). I saw this thread, https://wordpress.org/support/topic/404-error-publishing-post-with-html/ and I’m hosted with Namecheap, so I contacted them.

    Took about 15 minutes, but it was resolved as a false positive modsecurity on their side.

    Hi guys,

    my issue was also resolved now i think the server/hosting have some update and all things now are working properly

    abinashm

    (@abinashm)

    Okay, I thought of sharing what finally worked after 3-4 days of struggling and finally posted my query on WordPress forum where I explained similarly what some of your guys have faced.

    So if you tried disabling all plugins, disabled caching, tried another theme, reinstalled even WordPress, and nothing happens… it’s ModSecurity that’s casuing this issue due to security standpoint. All you have to do is just go to your cPanel > ModSecurity > disabled for your current domain (if you have more domains). If you have no access denied to ModSecurity, then contact your host, and they should disable this for you. Once it’s disable, your problem would be resolved.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘404 page not found when saving/updating a posts/page’ is closed to new replies.