Support » Plugin: AMP » 404 page error only when I visit appearance>>customize

  • Resolved Gabriel Nwatarali

    (@techhelpcanada)


    The customizer (appearance>>customize) stops working after I installed and set up AMP. Whenever I disable AMP, it starts working again. With AMP enabled, the customizer stops working. Gives me a 404 error.

    I had this issue with every theme I have tried, so I know it’s an issue with AMP plugin itself. I have also cleared cache several times and tested this issue on a different computer.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Weston Ruter

    (@westonruter)

    That’s strange. What is the the URL in the location bar when you try accessing the Customizer? It should be /wp-admin/customize.php with some query parameters.

    Please also share your site health information via our private form: https://forms.gle/3mjzvtLajyT8ewZZ8

    Thread Starter Gabriel Nwatarali

    (@techhelpcanada)

    Hi Weston,

    I have done as you noted. I filled up the requested details via the private form and shared site health information.

    The URL in the location bar is https://techhelp.ca/wp-admin/customize.php with some query parameters.

    I also checked that customize.php is in the directory and it is.

    Thank you for your help.

    Plugin Author Weston Ruter

    (@westonruter)

    Can you also share a screenshot of the 404 page you’re seeing? Is it the normal WordPress 404 template for the entire screen? Or is it a 404 showing in the Customizer preview only?

    Plugin Author Weston Ruter

    (@westonruter)

    There may be a conflict with one of the other plugins you’re using, or even the theme. Perhaps the best way to identify the conflict is to use the Health Check & Troubleshooting Plugin. You can see our guide for how to use here: https://amp-wp.org/documentation/playbooks/amp-plugin-troubleshooting-guide/#using-the-health-check-troubleshooting-plugin

    In short, enter troubleshooting mode and enable AMP and then enable other plugins one-by-one until you see the 404 behavior. The last plugin that you enabled in troubleshooting mode after which the 404 issue appears, that would be the source of the conflict.

    Thread Starter Gabriel Nwatarali

    (@techhelpcanada)

    Hi Weston,

    Alright, so the 404 error is the official one for all the pages. But I found the conflicting plugin, it was Shield Security (https://en-ca.wordpress.org/plugins/wp-simple-firewall/).

    However, since that plugin is non-negotiable, I decided to give up AMP implementation. I’ll have to find other ways to improve mobile page speed.

    Further, even after Shield Security was disabled, I could not use any of the other themes except Legacy, which is not great. Every time I selected a theme, it just gives me a blank page with a circle. I even installed them first.

    Maybe this information will be useful for the AMP theme to address such issues in the future.

    Thank you for your help.

    Plugin Author Weston Ruter

    (@westonruter)

    @milindmore22 Could you check for compatibility with WP Simple Firewall? It may be that they just need to allow more query parameters when accessing customize.php.

    Every time I selected a theme, it just gives me a blank page with a circle. I even installed them first.

    @techhelpcanada Could you share a screenshot of what you’re seeing here?

    Plugin Support Milind More

    (@milindmore22)

    Hello @techhelpcanada

    Can you please confirm that you have enabled Aggressive Scan in
    Configuratons -> Firewalls -> Aggressive Scan? it may be forcing to 404 error (screenshot)
    it may be creating a false positive warning as they mentioned.

    If yes, The firewall response may be set to 404 (screenshot) thats why you may be seeing 404 page(screenshot)

    I will suggest whitelisting the administrator or setting whitelist parameter (screenshot)

    Let me know if this resolves your issue.

    Thread Starter Gabriel Nwatarali

    (@techhelpcanada)

    Hi @milindmore22

    I can confirm that Aggressive Scan is off.

    I can also confirm that the Firewall response is set to Die With Message.

    I whitelist administrators and installed the AMP plugin again. Nothing changed. Same problems.

    https://prnt.sc/16x9oy2

    Plugin Support Milind More

    (@milindmore22)

    Hello @techhelpcanada

    I am unable to reproduce the issue at my end, it may be happening because of the combination of plugins and their particular configurations, which I think I can’t replicate given that there are 52 plugins active on your site.

    You may need to do a self troubleshoot again with Health and Troubleshooting plugin and confirm that the issue occurs by only keeping AMP and Shield Security plugins active if you didn’t find an issue, it may be some other plugin interfering with the result.

    Plugin Support Bethany Chobanian Lang

    (@shetheliving)

    @techhelpcanada As we haven’t received a response, I’ll mark this as resolved. Feel free to open a new support topic if you continue to encounter issues, or reopen this topic and we’d be happy to assist. Thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.