Support » Fixing WordPress » 404 on wp-admin after saving permalink structure

  • I just installed the latest 2.7.1. I updated my permalink structure as I’ve done many times before, only this time to find when re-visiting wp-admin it returns a 404 “Sorry no posts matched your criteria”. I’m a bit confused as the htaccess code is rather simple such as:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Anyone else having similar issues?

    -J

Viewing 15 replies - 1 through 15 (of 15 total)
  • I just got done reading over the past couple of hours, and it seems this isn’t uncommon and stems back to earlier releases of WordPress. Disabling all plugins, setting a tag and category base, all of those suggestions did not resolve this issue. Unless the default permalink structure is used, 404 errors occur on /wp-admin/ (only there from what I’ve seen thus far). So this is not a mod_rewrite issue, it is evidently a bug within WordPress. Is there any update?

    I guess noone knows the answer to this eh? :/

    Pretty sad, wow. Thanks WP!

    Same problem here.

    Yeah well they’re on top of their crappy releases, as you can see.

    Hi,

    I did a new install of WordPress V7.1 yesterday on a newly installed domain. Everything went smoothly until I changed my permalink option to customize. My new blog then — went crazy.

    After reviewing my install and finding nothing wrong, I decided to look at the server’s error log for the new domain. Bingo!

    The error log indicated a problem with the symbolic links. From my host’s control panel, I took a look at the “Web options.” I discovered that I had forgot to enable the “Symbolic Links” option. Once I selected this option and enabled it, the blog worked perfectly.

    I posted a new “Tip” on this at my blog: “When WordPress Permalinks Don’t Work“.

    ritvel,
    I read your response eagerly since I am having a similar problem with 404 errors on my posts after upgrading my site, An American in Lima, to WP 2.7. The pretty permalinks I was using for the past year now don’t work with my upgraded site; only the default setting works.

    I checked my error log, but it did not mention symbolic links. I only got these messages:
    Sun Mar 29 21:25:41 2009] [error] [client 200.121.137.100] File does not exist: /home/amerdra6/public_html/404.shtml
    [Sun Mar 29 21:25:41 2009] [error] [client 200.121.137.100] File does not exist: /home/amerdra6/public_html/wp-content/themes/Cutline 1.2-3ColumnSplit/custom.css

    I don’t know if your solution would help me. ideas?

    Hi, Americaninlima,

    If your host’s server settings did not change when you did your upgrade, I don’t think the problem is the same. The two messages you show indicate missing files, to me. If you did a backup before the upgrade, you should be able to upload the missing files.

    If you suspect an .htaccess problem, you could also upload a copy from your previous installation to the appropriate blog directory (backup any existing file before overwriting it).

    If you go back to the default permalink setting, do you see your posts?

    Can you create a new post and see it? If so, perhaps your previous posts do not exist in the MySQL database anymore. You can use phpMyAdmin to browse the post tables and check this from your host’s control panel, if there is one.

    One last thing you might try, as a diagnostic: what happens if you switch to the default WordPress theme?

    I could think up lots of other questions and things I might try if I were in your position. I hope this helps you a little in finding your problem. Please let us all know what your findings are. There is lots of expertise on this forum and someone may have other suggestions.

    rtivel,

    Yes, when I switch to the default permalink setting, I can click on any permalink and it works. (I have 174 existing posts.) The posts are there; what doesn’t seem to have “stuck” is the pretty permalink setting I’ve been using for the last year.

    I am able to create a new post and see it. The only permalink that works is the default one. If I switch to any pretty permalink format, I get a 404 error page.

    The permalink problem is still there when I switch to the default WordPress theme.

    I have disabled all plug-ins and actually eliminated all but one, which refuses to be deleted.

    I just discovered something weird: my .htaccess file has been changed (not by me) since yesterday.

    Yesterday it was 204 bytes and had the normal WordPress code.

    Today the file is just 35 bites and it reads:
    # BEGIN WordPress

    # END WordPress

    That is it.

    What should I do? Make a new .htaccess file? I have never done that before.

    When you customize permalinks, your .htaccess file should look like this (like the code quoted earlier in the post and assuming you are not using something like wp-supercache that also modifies the file):

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    My .htaccess file for this is 205 bytes.

    You might try to activate your custom permalinks again and then upload a new .htaccess file with the above code.

    Did you install wordpress in its own directory or are the files and folders in the root directory? Since I install my blogs in a default “wordpress” directory, I have to have a copy of the .htaccess and a modified index.php file in the root directory. If you installed the wordpress files and folders in the root directory, then try just uploading a new .htaccess file there.

    Note: in order to create a new .htaccess file, just open a plain text editor and copy/paste the code from the previous post into a new text document. Then, just save the file with just a file extension of .htaccess.

    See forum thread 257062 for further information on this problem.

    Sorry, got the link wrong. Here is the correct link: http://wordpress.org/support/topic/257062

    Update: I fixed the problem tonight not by following the ideas suggested on this forum.

    Instead, I took a chance and upgraded from 2.7 to 2.7.1.

    I don’t know what’s so different about the two versions, but 2.7.1 allowed me to change from the default permalinks setting to my old pretty permalink structure. The changes took effect immediately.

    americaninlima.com/

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘404 on wp-admin after saving permalink structure’ is closed to new replies.