Support » Themes and Templates » 404 on taxonomy archive pages

  • I created a custom post type with a new taxonomy and i keep receiving “404-not found” errors. The taxonomy is called “specialists_expertise”.

    Any advice besides flushing your permalinks structure, which i tried like a million times with no results? :((

    If i set the permalinks on “default” (URL/?p=123) it works like a charm, but once i choose a custom permalink structure the 404 error comes up.

    I added new posts, created the taxonomy-specialists_expertise.php, but no luck.

    I found quite a lot of references on the net or here on the forums about this issue, but 90% of them were solved when the permalink structure was flushed.

    Please please pretty please, anyone has experienced this before? I’m going mad over here :((

Viewing 4 replies - 1 through 4 (of 4 total)
  • I disabled all plugins – the problem persists on all the taxonomies, except for the regular wordpress “category”.

    I added flush_rewrite_rules() to the custom post and taxonomy registration and removed the ‘with_front’ => false and the 404 error is gone now, thank god!

    What does this “with_front” means exactly? I don’t get it from the codex explanation… 'with_front' - allowing permalinks to be prepended with front base - defaults to true => what does it mean?

    Also, with the 404 error gone I’m the happiest man on Earth, but now another problem came out: no posts found for all taxonomies, even if they have posts. Any idea?

    Ok, i found why was causing the last error too.

    When registering the custom post type for that taxonomy, i set the:

    'public' => true,
    'publicly_queryable' => true,
    'exclude_from_search' => true,
    'query_var' => true

    But it seems that the exclude_from_search must be set to false.

    Note: If you want to show the posts’s list that are associated to taxonomy’s terms, you must set exclude_from_search to false (ie : for call site_domaine/?taxonomy_slug=term_slug or site_domaine/taxonomy_slug/term_slug). If you set to true, on the taxonomy page (ex: taxonomy.php) worpress will not find your posts and/or pagination will make 404 error…

    Thanks for bearing with me, talking here alone 🙂 After all, maybe my monologue will prove useful to other guys trying desperately to find why they get a 404 or their posts are not showing up.

    So, to summarize:
    1. check your with_front (not yet pretty sure what it does)
    2. add flush_rewrite_rules(); to your code (this one is a gem)
    3. check your exclude_from_search
    4. check your taxonomy-NAME.php file
    5. PRAY

    Best wishes,

    Hey @atreidex, there’s no ne in this forum. I still have 5 pending questions and no one bother to answer. It’s a shame.

    I was looking for “what does with_front mean” in google, and end it up here in your topic. I suppose this is part f a big problem i’m having with my URLs.

    WHAT THE FFFFF does “with_front” mean!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘404 on taxonomy archive pages’ is closed to new replies.