The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] 404 on sub-directory sites on fresh 3.4.1 install (12 posts)

  1. cclonch
    Posted 4 years ago #

    The title says it all. Mostly. I receive a 404 error when I try to access the site or it's dashboard.

    I'm self-hosted running on Scientific Linux 6.2, Apache 2.2.15, and PHP 5.3. I've verified my htaccess is proper for sub-directory based network setups and that it is being read. I've verified the proper tables are being created for new sites.

    Now what is strange is this only seems to happen if I name the site 'chris'. I can create a site using any other name, or at least the hand full of names I tried, and they all work (test, demo, corbin, bob..). But when I create it named 'chris' it errors. I've tried deleting and recreating without success.

    My apache error_log shows the following when I access the 'chris' site:

    [Fri Jun 29 14:42:17 2012] [error] [client XX.XX.XX.XX] File does not exist: /srv/http/www/users, referer: http://www.theclonchs.com/wp-admin/network/site-new.php?update=added&id=9

    That would leave me to believe the 'chris' named site is slipping through the htaccess rules. So for reference here is my htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Any help would be appreciated! I'm out of ideas.


  2. cclonch
    Posted 4 years ago #

    And just incase you're wondering, this is completely fresh, no plugins or themes have been installed yet...

  3. Brit303
    Posted 4 years ago #

    I experienced the same problem when I upgraded to 3.4.1 from 3.4. What gives? Thankfully, my site and all its pages are visible, but I can't access the dashboard. (I get the 404 page response.) Any suggestions? Thanks!


  4. kellyvbrown
    Posted 4 years ago #

    I clicked on the "Please upgrade now" link to upgrade to 3.4.1, and I'm having the exact same problem as Tom. I get the 404 error when trying to reach the dashboard, but I can still see my site and all its pages. PLEASE HELP!!! I really need to be able to access the dashboard...of course!

    Here's a screenshot:

    I have 4 other blogs that need upgrading, but now I'm scared to do it!

  5. Mr.PiNGu
    Posted 4 years ago #

    i also got the same problem.. arghh.. i cannot access my dashboard at all.. I only can do so by rename the file in wp-admin-theme- by adding

  6. RichardWPG
    Posted 4 years ago #

  7. cclonch
    Posted 4 years ago #

    My issue is completely different. I did not upgrade but rather opted to setup a completely fresh install. Immediately after install I then switched it to a network install (which might not have been clear in my first post). So I can access the network dashboard and can properly manage the network. I can also access any site I create as long as I don't name it 'chris'.

  8. Brit303
    Posted 4 years ago #

    Mr. PiNGu:

    Can you explain your step? Where do you add the "old"? Is it in the URL, and if so, where? Thanks!


  9. Brit303
    Posted 4 years ago #

    Has anyone tried Mr.PiNGu's approach? I'm trying to figure out what he means. Can you explain it? Thanks.

  10. cclonch
    Posted 4 years ago #

    Please don't hijack posts that are not identical to your problems. See fourth bullet point.

    As an update to my problems, I wiped everything (files & db) and tried using just 3.4. This has the same problem, which just convinces me further that the problem is within my setup.

    I ended up stumbling upon this post. I am using Apache virtual hosts so I added the options listed. However this did not change anything.

    So I jumped over to my test virtual host and repeated the whole fresh setup of 3.4.1. Guess what, the 'chris' sub-directory site works. This means the problem is definitely in my virtual host config for http://www.theclonchs.com.

  11. cclonch
    Posted 4 years ago #

    I had an alias definied in my virtual host. Cleared that and my problem is resolved. I guess it helps to voice your problems so you can step through it "out loud".

  12. romuloctba
    Posted 3 years ago #

    Hi everybody.
    I don't know if it will aplly to you, but i FOUND A SOLUTION to my problem like yours.
    I had
    /directory/ -> wordpress installed here using DB 1
    /directory/newdir/ -> ANOTHER wp here using DB 2

    and directory/newdir/ stopped working, and showed /directory/ 404 error from WP on DB1

    What I did for fixing was changing /newdir/ chmod to 755 (it was 777 i think) and it worked.

    I hope this could help you

Topic Closed

This topic has been closed to new replies.

About this Topic