Viewing 9 replies - 1 through 9 (of 9 total)
  • I have the same problem and I had to restore my site 4 times because of this plugin. I am beginning to think its not worth the hassle. I mean while you are still logged in you are fine but as soon as you ever need to log back into the site, it keeps giving 404 and even the admin login page is stripped of all formatting.

    So what the heck gives? The developers don’t really support this unless you pay for it, which is ridiculous but maybe that’s their game, provide a broken product and break things so people have to pay for the support.

    I got help and had to go in a rename the .htaccess file and then it worked. Then I had to name it back to .htaccess so the site would come up again. Then the 404 error was gone. I deactived Better Security. Now today I have the same 404 on login page. Will any help be given to this topic? I want to know how to fix this error so that it doesn’t happen again or how to completely remove Better Security so that is stops causing this issue.

    Now I just deleted Better Security from server after it was already deactivated and now none of my url’s work

    Yeah it makes enough changes to critical areas that its like a virus that can’t be removed without a lot of work afterwards. I wish it just worked and/or the developers weren’t so greedy with the support and actually cared enough about the users to help out. Who knows if they were better at supporting this product, people might pay them in the long run. They are very shortsighted.

    I had to comeback and give an update on my situation. I realized that I needed to install the Better Security Plug in again to then go to the tweak panel and uncheck somethings. That would help me fix whatever was going on in the htaccess. After doing that, I saw where it had relocated my login to. I was happy to see that. So now, I know where to get to my admin page. Since doing that 3 days ago, I have had no further issues with this plugin. Now that I’m up and running without error, I just hope it is protecting my site as stated. I did ramp back up most of the tweaks since I found out what they were doing with my admin page. So far so good. I felt it was important to come back and say that everything is okay now. As with many things, people(including me) get frustrated and we may leave a review or whatever but if we find solutions we never go back and update our reviews. However I will say this, I did not receive any help from the official plug in guys. I figured this out all on my own. So I will say that they should step that area up.

    Thank you but can you specify what “something” you unchecked to get it working again. Plus, I have noticed that no matter what you do, its temporary. Every time you use the slug for login, admin or anything, it will trigger a 404 or will take you there with no formatting and then fails to authenticate and 404’s again. The only way to fix it is to delete the .htaccess and go directly to the wp-login or wp-admin and so far that’s the only way to make it work and that’s just absurd.

    Today I’m experiencing a new issue. When I go to edit one of my pages I get: Fatal error: Call to undefined function wp_mail() in /home/content…..wp-content/plugins/better-wp-security/inc/backup.php on line 159.

    I am totally sick of this plug in now. It appears to be always something and they offer 0 help. I would advise users to try a different security software. I turned off all of the tweaks and the error still persist. I’m afraid it will do this to additional pages going forward until all of my pages can’t be edited. Anyone know how to help?


    I can’t replicate your problem.

    Have you upgraded to WordPress 3.6? If you haven’t, please try this first, it is safe to do so.

    Did you update the BWS plug in? Another update was released recently.



    I had the same problem, not with login, but with logout, so I have deactivated the plugin and now everything works fine.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘404 on Sign in page’ is closed to new replies.