Support » Plugin: Duplicator - WordPress Migration Plugin » 404 On Posts and Pages

  • Resolved carinallc

    (@carinallc)


    Hello

    I just downloaded to try out, migrating current site to a MAMP-install.

    No errors during the process, and the site *looks* fine. But, all my post, page links return 404.

    I can Add/Edit pages and posts. And, I can *view* them prior to publish. But once they public, I get a 404 when trying to access them.

    This was a basic WP site to test the plugin in on – just not quite sure what the issue may be.

    Thank You

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    You might check your permalink settings and see if they are correct it’s under Settings > Permalinks….

    Let me know if that helps~

    carinallc

    (@carinallc)

    Thanks for replying Cory, I’m really anxious to see if Duplicator will fit my needs.

    Ok, the Permalinks are exactly what I have them set to on the original site.

    What I have noticed is that if I create s new post, I can Preview it
    http://localhost:7888/?p=1957&preview=true

    But once I Publish, I get a 404 on this link.
    http://localhost:7888/mytestpost/

    carinallc

    (@carinallc)

    Cory – my apologies.

    I loaded NGINX for a reverse proxy, and didn’t take that into account. That was the difference.

    Lesson learned. Thanks for replying, sorry for the false positive.

    Chris

    Plugin Author Cory Lamle

    (@corylamleorg)

    Excellent! Thanks for the update.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.