DW Question & Answer
404 on new questions (11 posts)

  1. coolhand1980
    Posted 1 year ago #

    Hi there - I installed made a question but can not see questions or answer them in back end - please help :)


    best! Luke


  2. DesignWall
    Plugin Author

    Posted 1 year ago #

    Please help us to update your dw-question-answer/dw-question-answer.php file with this file https://github.com/designwall/dw-question-answer/blob/master/dw-question-answer.php we will release this fix in upcoming version.

  3. Kostis_P
    Posted 1 year ago #

    I had the same problem plus a blank page on firefox (on I.E. Internal Server Error 500)or when i was trying to make a question.

    Tried the code above and broke down the ask-question page and the plugin's settings to the back-end as well.

    this is the questions page

    Thank you.

  4. Kostis_P
    Posted 1 year ago #

    OK, went back and changed the code as it was.

    I found a solution about 404 on questions. Did the permalink settings thing that i found in this topic and worked like a charm! Now i can see all the questions.

    But I'm still having the same problem when i'm trying to submit a question
    The question is been published but the screen goes blank (or gives an internal server error on i.e.) Same thing happens when i try to answer a question too.

  5. DesignWall
    Plugin Author

    Posted 1 year ago #

    Hi Kotis_P,
    can you go to designwall.com/question and submit a private question with a admin account, it will help me to check and resolve your problem.

  6. Kostis_P
    Posted 1 year ago #

    Hi there and thanks for the quick reply!

    Right now i'm facing some problems with my server. The physical machine went out of power supply so my hosting company moves the virtual machines right now to another server.

    As long as they finish and the site is live again i'll send you via private question as you said an admin account login information.

    Thank you so much for your fast reply once again.

  7. Kostis_P
    Posted 1 year ago #

    Hello there... again!

    It seems like you won't have to be in trouble. I fixed and it was pretty simple.

    I turned on wp debug an saw that when i was trying to submit a question or an answer i was getting a fatal error like this:

    Fatal error: Call to undefined function bp_blogs_record_activity()

    I did a little search on your site an found that i had to turn site tracking on in buddypress.

    So simple as that. Problem solved for me but thanks once again for your will to help!

    p.s. Sorry in advance for the offtopic but i've already translate the front-end of your plugin for my site in greek. I think there is no other available translation in Greek so if you are intrested for it let me know to continue tranlate the back-end as well when i find some time and also where and who to contact with.

  8. pimlfo
    Posted 1 year ago #

    I have installed 1.2.10 version but 404 page still display when i click to single question.
    Please advise.

  9. Newest
    Posted 1 year ago #

    I am having the same problem ..please advise ...after installing haven't been ab;e to move beyond the 404 error !

    Site is at :


    Do I need to fiddle around with Buddypress after installing it ? I don't plan to put in BP at the moment...

    All advise much appreciated.

  10. esmi
    Forum Moderator
    Posted 1 year ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic instead of tagging onto someone else's topic.

  11. Newest
    Posted 1 year ago #

    @esmi - noted and learnt, wil do, thanks !

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • DW Question & Answer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.