Support » Plugin: rtMedia for WordPress, BuddyPress and bbPress » 404 on media pages in groups

  • d3fcon

    (@d3fcon)


    It seams the media pages are not being created.
    example
    domain/groups/groups-name/media is giving 404 or page does not exist errors.

    I am noticing a jquery issue also
    “buddypress-media/app/assets/admin/js/admin.min.js: jQuery.fn.load(”

    The link should be for one group as shown below
    https://4x4aus.com.au/groups/4x4aus-general-group/media
    but that page does not exist

    Any ideas guys ?

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Pooja N Muchandikar

    (@pooja1210)

    Hi @d3fcon,

    Sorry to hear the inconvenience you are facing at your end.

    We tried to reproduce the issue but unable to replicate it. Group media pages are working fine.

    Can you please share more details/issue visual? For us to understand the issue and debug the issue.

    Looking forward to hearing back from you.

    Regards,
    Pooja

    Thread Starter d3fcon

    (@d3fcon)

    This is the media link button, it directs to /group-name/media
    https://i.imgur.com/06pcpz3.png

    The group media pages are not being created when a group is created and because of that the pages are 404 because they do not exist.

    This button links to
    https://4x4aus.com.au/groups/4x4aus-general-group/media

    Plugin Contributor Pooja N Muchandikar

    (@pooja1210)

    Hi @d3fcon

    Can we get your staging site details? So that we can check the issue over there.

    Meanwhile, can you please create ticket here https://rtmedia.io/support/?

    Regards,
    Pooja

    Plugin Contributor Pooja N Muchandikar

    (@pooja1210)

    Hi @d3fcon,

    Can you please try saving the permalinks setting?

    Path: Go to Settings in the left sidebar > Permalinks > Click on Save Settings button

    Let us know if this works for you.

    Regards,
    Pooja

    Thread Starter d3fcon

    (@d3fcon)

    Sorry, still the same result. it’s odd.

    Question, When groups are created via buddypress does it create a media page for that groups ? or is that the role of rtmedia ?

    Because the page that is supposed to contain the media fails to be created or exist and that’s why the /media page is 404 on any group.

    Current Perma setting is
    https://i.imgur.com/5FIGsQM.png

    • This reply was modified 7 months, 4 weeks ago by d3fcon.
    Plugin Contributor Pooja N Muchandikar

    (@pooja1210)

    Hi @d3fcon,

    rtMedia has a PHP template file that is displayed on the media page.

    Could you please deactivate all plugins except rtMedia and it’s add-ons and then switch to WordPress default theme (twentytwenty/twentynineteen/..), save the permalink once and check if its works?

    Regards,
    Pooja

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘404 on media pages in groups’ is closed to new replies.