Support » Installing WordPress » 404 on local install–getting frustrated

  • I’ve never tried to configure web server software and I’m very frustrated here. I followed instructions here to install apache2, MySQL, and PHP5 on the latest version of Ubuntu. When I try to browse to either http://localhost or http://localhost/wordpress, I get

    Not Found
    The requested URL / was not found on this server.
    Apache/2.2.11 (Ubuntu) Server at localhost Port 80

    I don’t know how to troubleshoot something like this and I’m finding surprisingly little online (at least that I can understand). Could anyone provide some insight? It’d be much appreciated.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Sorry – not really. The error simply says that the web server returned an error that the specified page requested does not exist.

    The fact that you’re getting an error from Apache tells us – thats working at least !
    Things to try (somewhat basic) – was the ‘wordpress’ director spelled correctly – remember its case sensitive, so ‘WordPress’ isn’t the same.

    Is the wordpress directory in the correct root folder (all web servers require a ‘starting root’ – I’m not that familiar with Apache on Ubunu, so can’t tell you where to look.

    The next thing to try is whether PDP is running, and whether the .php file is in the default list of files.
    Try checking the above directories are in the right place, spelled correctly and then put the specific file in your browser address bar ( to find the exact file) – ie http://localhost/wordpress/index.php
    if you still get a 404 error then Apache really cannot find the file where it expects. If you get text showing the <?PHP etc, then PHP isn’t installed correctly.

    The path is
    From my understanding, that was the correct place to extract the files. I don’t what you mean by PDP–might you mean PHP? In any case, I’m not sure how to check whether it’s running. If I click on the link to the index.php file, I get a message from Firefox asking whether I want to run or save the file. From my understanding, when things are working correctly it should take me directly to that page in my browser, correct?

    yes, sorry, PHP…. – in that case, Apache isn’t running the PHP scripting engine.
    Explanation : Apache should recognise the .php extension of the file your browser is asking for and then pass the PHP script through the PHP engine.
    Not sure I can help much further with specifics (I’m on Windows platform)…

    I found that the PHP install instructions – although voluminous, its easy to get lost – and many of the instructions are based on older versions which aren’t appropriate (or weren’t in my case).

    I suggest you do a Google for installing PHP on Apache and find some that do a step by step ‘walkthrough’, that ends with a test to show its working.
    Then go back to your wordpress stuff, and retry.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘404 on local install–getting frustrated’ is closed to new replies.