404 on images despite permissions and directory existence (4 posts)

  1. cieron
    Posted 6 years ago #

    Hi, WordPress community. Just migrated my site over here from Expression Engine (quite a task), and so far so good. Except...

    I have WordPress installed in a sub directory, but using the workarounds to run it directly from http://www.mydomain.com. This has gone off without a hitch until just a few hours ago, when I noticed some images not only disappearing in my blog, but also returning 404's when trying to access them independent of WordPress.

    I'm getting 404's on images from the image_gallery directory on my server, but only on the imaages I've uploaded in a WordPress post for whatever reason. For instance, if I try to access the URL http://www.mydomain/image_gallery/a-image-that-has-been-used-in-a-wordpress-post, I get a 404. Any other image in the directory can be pulled up via the web fine, however.

    I have to think that one of the plugins I've installed, or perhaps a config file issue, or something, is causing this, but, despite exhaustive Google research, I'm at a loss at where to start.

    Plugins I've installed: WP-Super Cache (likely culprit, given the .htaccess rewriting requirements, me thinks), Google XML Sitemaps, and Add To Any Social Bookmarks.

    Many thanks in advance for any assistance anyone can provide.

  2. cieron
    Posted 6 years ago #


    To be more direct (and hopefully illicit a response):

    If I upload "image.jpg" from my local computer to WP's image custom field (which creates a file on my server located at http://www.my domain.com/wp-content/uploads/2010/01/image.jpg)...

    The path to the same file located in a different directory, http://www.mydomain.com/image_gallery/image.jpg then, and only then, begins to return a 404 error. However, any image in this directory that has not been uploaded to WP is completely accessible.


  3. mskogly
    Posted 6 years ago #

    I think I might have the same problem. I store the url for some of my post images in custom fields.

    But on my blog ALL custom field values are stripped out, wordpress isn't able to access any of them as long as WP Super Cache is ON og Half On.

    This has to be a bug?

  4. scottmanesis
    Posted 6 years ago #

    This just started happening today.

    To be clear this is the first post I am trying to make since moving my wordpress blog from http://www.scottmanesis.com to http://www.scottmanesis.com/blog

    this image was loaded before the move
    http://www.scottmanesis.com/blog/wp-content/uploads/2010/07/team-300x251.jpg and works just fine as a full size image and as a thumbnail

    Now I just went to make a new blogpost the same exact way and this image http://www.scottmanesis.com/blog/wp-content/uploads/2010/07/logo.png

    gives a 404 and the thumbnail does not work and I have given a 777 permission to all the files on the blog and still get the same results. Its not just this image, I have tried several.

    What is really interesting is if I choose gallery within the area where you make and edit posts I can see the image just fine but in the thumbnail section it just says "edit image" which does pull the image up when I click on it, but it wont let me edit it.

    *shrugs* please help!!!!

    Scott Manesis

Topic Closed

This topic has been closed to new replies.

About this Topic