WordPress.org

Support

Support » Localhost Installs » [Resolved] 404 on form submit (no reserved terms)

[Resolved] 404 on form submit (no reserved terms)

  • I have an email form that takes me to a 404 on post, instead of running the mail script.

    I Googled and found the problem 99% of the time is that people are using fields with reserved terms, such as ‘name’. That’s not the case for me.

    In fact, I can comment out all my inputs except for <submit>, and I still get 404. So it must be the <form action=””> parameter.

    Could it be an error with using localhost? Will it work once I go live?

    (this site is for a Spanish audience so my code is kinda spanglish)

    <form method="post" action="<?php bloginfo('url'); ?>/submit-contacto.php">
        <input type="text" id="form_nombre" name="form_nombre" />
        <input type="text" id="form_correo" name="form_correo" />
        <input type="text" id="form_asunto" name="form_asunto" />
        <textarea id="form_mensaje" name="form_mensaje"></textarea>
        <input type="submit" value="Mandar" />
    </form>
Viewing 3 replies - 1 through 3 (of 3 total)
  • [SOLVED]

    Don’t you love when you ask a question, just to figure it out yourself minutes later?

    The problem was I had “submit-contacto.php” within my theme files. It should have been in the root.

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    Now if you’d just figured out that instead of adding [SOLVED] to the title (which I’ve removed) you could have just used the drop down on the right to mark this [RESOLVED] (which I’ve also done)… 😉

    Noted. I’m new here 😉

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] 404 on form submit (no reserved terms)’ is closed to new replies.
Skip to toolbar