WordPress.org

Support

Support » Plugins and Hacks » WPNewsman Lite » [Resolved] 404 on action pages

[Resolved] 404 on action pages

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author G-Lock Software

    @marisp

    Do you have our old plugin G-Lock Double Opt-in Manager activated? If so deactivate it and try again

    Thank you for your answer.

    I don’t have the G-Lock Double Opt In Manager actived. It is possible that I installed it before but currently it is not present in the list of plugins, or in the /plugins/.

    Plugin Author G-Lock Software

    @marisp

    Hi,

    In order we can find out why WPNewsman does not work on YOUR site, we need:

    1) full access to your FTP server to be able to edit the wp_config.php file and enable/disable the WP_DEBUG option;
    2) test admin account on your blog where you installed WPNewsman to be able to de-activate/activate all plugins;
    3) access to your cPanel to see the error log.

    If you have a production site and you cannot provide us with the above, please, search for the alternate plugin and do not use WPNewsman.

    If you have a test site and you can give us the access to your FTP, cPanel and test admin dashboard on your WordPress, please, place a support ticket here http://support.glocksoft.net/new-ticket and send us the required information.

    I have activate the debug mode.
    I obtain some errors.

    Juste above the form :
    Notice: Undefined index: checked in /xxxxxxxxxxxx/wp-content/plugins/wpnewsman-newsletters/class.form.php on line 181

    And when i try to access a action page :
    Notice: Trying to get property of non-object in /xxxxxxxxxxx/wp-content/plugins/wpnewsman-newsletters/core.php on line 160

    In the core.php, $post isn’t exist in the onTemplateRedirect function.

    Maybe this can help you ?
    If not, i will contact the support as you said.

    Thank you !

    Plugin Contributor neocoder

    @neocoder

    Hello,

    thanks for the info. I added a check for the $post variable but I think this should not cause a 404 page.

    Could you go to Action Pages in WPNewsman menu and view any page via the link that appears under the name of the page. Or via the “View Action Page” if you open the page in the editor. If the page will be shown check the URL of the page and how it different from the one that plugin tries to use.

    If a URL is the same, please let me know what theme and plugins do you use?

    Regards,
    Alex L.

    Hello,

    it’s work !
    I delete il wp_options the “rewrite_rules”.

    And now it’s fine.

    Hello,

    it’s work !
    I delete il wp_options the “rewrite_rules”.

    And now it’s fine.

    Hello,

    it’s work !
    I delete il wp_options the “rewrite_rules”.

    And now it’s fine.

    Hello,

    it’s work !
    I delete il wp_options the “rewrite_rules”.

    And now it’s fine.

    Hello,

    it’s work !
    I delete il wp_options the “rewrite_rules”.

    And now it’s fine.

    I have the same problem, Action pages works only using “Deafault” permalinks, what is not good for SEO.

    Can yoo please describe which file did you change and in which line.

    Thanks in advance

    Plugin Contributor neocoder

    @neocoder

    Here’re some things you can do to solve the problem:

    First, go to Options → Permalink in wp-admin and re-save your current URL structure(Switch to different one, press Save and then change it back to the desired structure and press save). This will rebuild the rewrite rules of wordpress and should add action pages rule if it was missing.

    Second, make sure you don’t have page or category with the name “subscription”. For example, if you have category “subscription” and will try to open http://your-site.com/subscription/confirmation-successful/ wordpress will try to load a page with the slug “confirmation-successful” from the “subscription” category. Most likely you don’t have a page with this slug so it will show a 404 page and won’t pass the request to the action pages.

    Alex

    Nothing happens. I made it several times, switched off and switched on the plugin and still the same problem. I have the following text page No Results Found “The page you requested could not be found. Try refining your search, or use the navigation above to locate your post.”

    There are no subscription catetegories or pages.

    Plugin Contributor neocoder

    @neocoder

    Could you create a temporary administrator account and send me the login and password to alexladyga@glocksoft.com so I can check the issue myself?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] 404 on action pages’ is closed to new replies.
Skip to toolbar