Support » Fixing WordPress » 404 not working after upgrade to 2.0.1

  • After I upgraded from 1.5.2 to 2.0.1 my 404-page stopped working. Instead I get the following error:

    “The requested URL /php-bin/index.php was not found on this server.”

    So far I have tried:
    1) to update the permalink structure to both “/%year%/%monthnum%/%day%/%postname%/” and “/archives/%year%/%monthnum%/%day%/%postname%/”. That didn’t help

    2) to let WP create the .httacces file from scratch to make sure other rules weren’t causing the error.

    3) I also tried to specify the path to the 404 document in the .htaccess-file (ErrorDocument 404 /index.php?error=404)

    The .htaccess-file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    # END WordPress

    Any ideas?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Same problem here… Any help?

    I think I may be having the same problem over at my place:

    Everything appeared fine on the main page until I hit one of the permalinks and got a “404 Not Found – The requested URL (followed by the post slug) does not exist”

    Ditto for comments (although their presence is still displayed), because those attach to the individual post URL.

    The post still exists, since if I access it by post number rather than url/slug, the permalink and comments work.

    Tried the install twice, gave up and tried to “roll back” using the saved WP files and the database back up, but got this error message from phpMyAdmin: Fatal error: Maximum execution time of 300 seconds exceeded in /usr/local/cpanel/base/3rdparty/phpMyAdmin/libraries/read_dump.lib.php on line 91

    So I’m a little, you know: Frustrated.

    Any ideas on how to rescue the posts? How to extend the time available (if that’s the issue) on phpMyAdmin?

    Well, I guess I wanked too soon. All better now. Not sure if this is the same problem to which you were referring, but I set the default theme, turned all the plugins off (again) deleted everything from the server except the wp-config, content and images folder and reinstalled one more time.

    After that reset my theme and went through the plugins one at a time. Had to goof with runPHP and ELA through a few sequences to get it right.

    Good luck.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘404 not working after upgrade to 2.0.1’ is closed to new replies.