WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] 404 Not found when updating options

[Resolved] 404 Not found when updating options

  • Hi

    I’ve browsed through the threads and found several people have had the same problem as I in this thread http://wordpress.org/support/topic/34165?replies=6 but there seemed to be no definite solution to their problems.

    I downloaded and successfully installed WP last night. However when I was trying to change some of the “general options” and click “update” I am directed to http://www.littered.org/wp-admin/updated=true “404 Not Found”

    I have installed WP into the root of my domain.

    Just wondering if anyone could help shed some light. I would be most thankful 🙂

    Many thanks

Viewing 15 replies - 1 through 15 (of 22 total)
  • That seems to be a bug. There ought to be a file there and a ? delineating between the URL and the query string.

    So: example.org/wp-admin/options.php?updated=true

    You might consider submitting a bug report, if it repeatedly happens.

    http://codex.wordpress.org/Submitting_Bugs

    I have made it’s fix. You can download it at http://www.ishbir.com/wpfix1.zip. Unzip the file to you wp-admin directory and replace the previous options.php file. Test it. If any problem mail me a at webmaster(at)ishbir(dot)com.

    Hi Maerk – not sure if there are many other people experiencing the same problem as I, is it worth submitting the bug report?

    Hi Ishbir – I’ve tried your options.php file and I’m still having the same problem.

    Many thanks

    Read the next post

    Please download it again. I made the file again and did a mistake. Now it is fixed and tested. Download it from the same link.

    Ishbir: What changes did you make to the options.php file? Because if I do a diff on yours and the original one from 2.0.3, I don’t see any differences.

    nosila: Do you have mod_security running? If so, read this topic and see if that helps.

    Please download the file again and see the diffrences becuase I uploaded the wrong file with the bug again.

    Please see the differences in the line $goback = add_query_arg('options-general.php?updated', 'true', $_SERVER['HTTP_REFERER']);. Firstly it was $goback = add_query_arg('updated', 'true', $_SERVER['HTTP_REFERER']);

    I just did, and it’s still the same as the original.

    It’s got this line in your download as well:
    $goback = add_query_arg(‘updated’, ‘true’, $_SERVER[‘HTTP_REFERER’]);

    Please check it again or download it again and check. This line of ‘$goback’ is different. Open both the files and then navigate to the same line and check it carefully becuase sometime even I can’t see the differences.

    That’s why we have comparison tools. 🙂
    Both Araxis Merge and good old DOS FC declare the files identical.

    Don’t use tools, check it by yourself or download the file again and check it yourself.

    I DID!

    I even asked a friend of mine to download it and take a look, but they’re identical for him as well.

    Evidence

    Have you found the difference or not?

    No, still no differences.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘[Resolved] 404 Not found when updating options’ is closed to new replies.
Skip to toolbar