Support » Fixing WordPress » 404 Not Found Eror when saving post with hyperlink added

  • Resolved taffyc

    (@taffyc)


    Hi There,

    This just started happening to me today. When I create a new post I can enter content and save fine (I haven’t published yet) but when I add a link (any kind – internal or external) when I try to save the page redirects to one with a URL of:

    My URL/wp-admin/post.php

    And I get this message on the page:

    404 | Page Not Found!
    Sorry, but the page you were looking for is not here.

    When I go back to the previous page I am returned to the post-writing page and the link has not been saved.

    I’ve tried logging out and back in, clearing browser cache, etc but no change. I can save any changes fine – just not links.

    I’ve been running this site for years and have never seen this problem. Any clues appreciated!

    Thanks …. TC

Viewing 15 replies - 1 through 15 (of 20 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Thanks esmi. I tried everything you mentioned except resetting the plugins folder – not sure how to do that with FTP? Deactivating plugins and switching the theme to Twenty Ten didn’t make a change.

    A new piece of data I’ve discovered. If I write only a short post with a few links everything works OK, but once I go beyond a certain number of links it starts to happen. I’m not sure exactly how many but the limit seems to be 4 or 5 links. I haven’t written a long post for a while so I can’t be sure when this started to happen.

    I’ve also tried increasing PHP memory to 128M but no improvement.

    I’m wondering if this is possibly a WP 3.13 issue?

    Appreciate any further thoughts.

    Thanks … TC

    esmi

    (@esmi)

    Forum Moderator

    not sure how to do that with FTP?

    Please see the link I gave above.

    I’m wondering if this is possibly a WP 3.13 issue?

    No – this appears to be specific to your site.

    Thanks esmi. Tried that and no change. I’ve opened a support ticket with my server host to see if they have any input.

    Hey thanks for letting me know.
    Can you list plugin that you use? Maybe we can cross-match and identify what plugins might cause that. I got a live site and can’t deactivate them.

    Thanks,
    Viktor

    I have deactivated all my plugins and still have problem.

    Who is your hosting provider and do you use CloudFlare by any chance?

    esmi

    (@esmi)

    Forum Moderator

    Seems like a related topic here

    The issues are quite different & unrelated. Have you tried resetting the plugins folder by FTP or PhpMyAdmin yet?

    esmi – yes – I reset the plugins folder with FTP exactly as per your link

    The issues are quite different & unrelated. Have you tried resetting the plugins folder by FTP or PhpMyAdmin yet?

    That’s exactly what happened to me, but I wrote it up differently in the forum.

    viktorix – re webhost. No – I am on a liquidweb VPS

    taffyc, have you looked at mod_security? You can ask Liquidweb to set it to allow WordPress through it, and that may help. I had the same problem ages back.

    esmi

    (@esmi)

    Forum Moderator

    Wow – they must have the servers tied down tight if a single link creates a problem! The other poster’s issue looks more like a server problem. It’s intermittent – and possibly random (?) – for a start

    lpstenu – thanks – they suggested modifying wp-admin/post.php to exclude mod_security rule id 300015

    Is that the same as what you are suggesting? Or should they be tweaking the server settings??

    esmi – they do seem to be pretty security conscious.

    Thanks … TC

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘404 Not Found Eror when saving post with hyperlink added’ is closed to new replies.