WordPress.org

Support

Support » How-To and Troubleshooting » 404 not detected

404 not detected

  • I’m having trouble with my 404 page, it doesn’t show.
    Every URL that i type in is accepted and only leads to an empty page with normal sidebar/menu.
    If i go to a page that shouldn’t exist it returns 301 instead of 404 and the 301 points to the same URL as i entered.
    If i try to access /index.php?error=404 it just returns the main page.
    Does anyone have a clue?

    This is the 404.php for my theme:

    <?php get_header(); ?>
            <div id="content" class="narrowcolumn">
                    <h2 class="center"><?php _e('Error 404 - Not Found', 'minimalism'); ?></h2>
            </div>
    <?php get_sidebar(); ?>
    <?php get_footer(); ?>

    And this is my .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I’m also running WP Super Cache 8.7 but it makes no difference if i disable the plugin.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I have exactly the same problem. While I have permalinks activated, /index.php?error=404 throws me to the home page, but without permalinks it shows my custom 404-page. Does anyone have a solution?

    I’m having a similar issue. I recently moved my wp site to a new server and now it seems that most directories (images, cgi-bin, etc) send a 404 error even though the directs/files exist on the server.

    A little update. When i check at the response codes from WP with FireBug when i try to get the page “http://mypage/sdfg” i get this:

    301 Moved Permanently (which points to “http://mypage/sdfg/”)
    401 Not Found

    And then my 404 page doesn’t show up. If i turn off permalinks it works as expected. Any thoughts?

    epoks, what do you mean by “when I have permalinks activated”?

    Have you tried using different permalinks styles?

    At first I thought this had to do with my use of “/%postname%/” but I’ve tried the default permalinks and still have the problem. No one seems to know the answer or is listening in these forums … I’m doing archive searches and see the same question again and again for over a year, no answers. It’s depressing!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘404 not detected’ is closed to new replies.