Support » Plugin: WordPress SEO Plugin - Rank Math » 404 Monitor Log

  • Resolved Sean

    (@sbwcws)


    My 404 Monitor Log is empty – Is there any special settings I need to do for 404 to show, I am using NGINX and its a dedicated server no control panel. I do see some 404 in my nginx log file but not on the log monitor its just empty. Please let me know if there is some settings I need to do in order for them to show.

Viewing 8 replies - 1 through 8 (of 8 total)
  • What do you see when you hit a URL that doesn’t exist in your browser? Rank Math can only record them if they are hitting WordPress.

    What does your nginx config look like?

    try_files $uri $uri/ /index.php?$args;

    Plugin Author Rank Math

    (@rankmath)

    Hello @sbwcws

    Thank you for contacting the support.

    As @hendridm, the Rank Math plugin can only detect the 404 URLs if they are hitting WordPress.

    To determine that, you can run a small test by visiting a page link:
    https://website.com/404page

    If that gets recorded in the RM plugin, then everything is working as intended.

    Please let us know.

    It’s not getting recorded but yes I can see it in my NGINX LOG

    My NGINX Config is

    
            # index.php
            index index.php;
    
            # index.php fallback
            location / {
                    try_files $uri $uri/ /index.php?$query_string;
            }

    I even tried with

    try_files $uri $uri/ /index.php?$args;

    Plugin Author Rank Math

    (@rankmath)

    Hi @sbwcws

    Please check if the config file contains the following line:

    fastcgi_intercept_errors on;
    

    Turn the setting off:

    fastcgi_intercept_errors off;
    

    Also, please look for this part, or anything else related to 404s and delete it:

    error_page 404 /404.html;
    location /404.html {
    internal;
    }
    

    Make sure to reload nginx after editing the config file, so the changes can take effect.

    Hope that helps.

    • This reply was modified 1 month, 2 weeks ago by Rank Math.

    I’ve just this line which I’ve tried commenting it but still has no effect.

    # 404
    #try_files $fastcgi_script_name =404;

    Plugin Author Rank Math

    (@rankmath)

    Hi @sbwcws

    Please try adding the fastcgi_intercept_errors off; line to the config.

    Let us know how that helps.

    Plugin Author Rank Math

    (@rankmath)

    Hello,

    Assuming you are using the latest version of the plugin and the issue is not happening, we are closing this topic.

    If that is not the case, please feel free to reply to this topic or open a new one and we would be more than happy to assist.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.