Support » Plugin: Google XML Sitemaps » 404 File Not found? See here!

  • Plugin Contributor Arne Brachhold

    (@arnee)


    In case you get an error that your sitemap file was not found, please follow these steps:

    1. Check your permalinks settings of WordPress and click the Save button
    2. If you are using nginx as a webserver, place add the Rewrite Rules manually. see here
    3. If you are using W3 Total Cache and activated the “Do not process 404 errors for static objects with WordPress” feature under “Browser Cache”, please add the rules stated below to the “404 error exception list”.
    4. If you have still problems, please post here.

    Rules for W3 Totacl Cache 404 error exception list:

    sitemap(-+([a-zA-Z0-9_-]+))?\.xml(.gz)?
    sitemap(-+([a-zA-Z0-9_-]+))?\.html(.gz)?

    https://wordpress.org/plugins/google-sitemap-generator/

Viewing 15 replies - 31 through 45 (of 45 total)
  • Can you explain to me the difference? Because if the new version keeps the sitemaps in different locations, then how come Google Webmaster tools couldn’t find them and kept giving me no sitemap found? But when I put a static sitemap in the root, the plugin tells me there is a conflict. One of them is not looking in the right spot. It’s not that I don’t believe it working, I am just getting errors no matter which option I use.

    Managed WordPress Account

    My Site : http://www.softfully.com

    Respected Sir,

    Past 24 hours i am receiving error in my “XML Sitemaps – Yoast WordPress SEO Version 1.5.5.3” : http://www.softfully.com/sitemap_index.xml and also same error in “Google XML Sitemaps Version 4.0.7” : http://www.softfully.com/sitemap.xml = So all .xml file are receiving below errors.

    500 Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    I also try to enable, disable and reset plugin but no results in my sitemap.xml file format (.xml file format not working)

    I can see my sitemap in debug function.

    I also try to edit “.htaccess file” but still not working.

    I need help please.

    Thank you.

    @metuckness

    The old version of this plugin created a static sitemap file, while the new version does it through WordPress. If you think about when you create a blog post on your blog, this doesn’t create a physical file in your wordpress directory. But WordPress dynamically creates and serves the content for that page. The new version of the plugin does the same thing, but for sitemap files rather than blog posts.

    If you have a static sitemap file, then this creates a conflict with the new version of the plugin, as the static file will be served rather than the dynamic one through WordPress. (Actually it depends how your server is configured, but most configurations for WordPress serve a file if it exists and otherwise direct the request to WordPress).

    @softfully

    It sounds like you have sitemaps enabled in the Yoast SEO plugin (in which case you have no need for this plugin), which is creating a conflict. Possibly you have some server configuration issues as well, e.g. if both the Yoast plugin and this plugin added rewrite rules for the sitemap then it could end up in an infinite loop and you’d get a 500 error.

    Now its working fine.
    Thank you.

    I did not want to use a plugin to exclude a category so I pasted:
    ‘<?php
    function exclude_widget_categories($args){
    $exclude = “14744”; // The IDs of the excluding categories
    $args[“exclude”] = $exclude;
    return $args;
    }
    add_filter(“widget_categories_args”,”exclude_widget_categories”);
    ?>’
    into my functions.php file.
    I got a: XML Parsing Error: XML or text declaration not at start of entity error when I viewed the http://www.b4usa.com/sitemap.xml link.
    All is well now because I am using a plugin, but I would like to use the code and get rid of the plugin. Do you have any advice?
    Thanks in advance,

    The removed the closing ?> , works fine now!

    <?php

    function exclude_widget_categories($args){
    $exclude = “14744”; // The IDs of the excluding categories
    $args[“exclude”] = $exclude;
    return $args;
    }
    add_filter(“widget_categories_args”,”exclude_widget_categories”);

    Hi,

    I had same problem, so what I did was to uninstall the latest version and I installed version 3.3 where it has the rebuild sitemap option, and happy now 🙂

    Regards

    Hum, seems it does not work in google webmaster tool. Once uploaded, it says General HTTP error: 404 not found
    HTTP Error: 404

    and

    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit.

    Is the plugin really compatible with google tools ? Our site is superav

    Hi,

    I am having the common issue with 404. Google Webmaster Tools reports that Googlebot couldn’t crawl URLs because they point to non-existent pages.

    URLs with 404s are coming from non-existing: galleries (all gallery links with “feed” extensions), tags, pages, and some non-existing categories, uploads, attachments and autoopitimizations.

    I am using 4.0.8 plugin version, W3 Total Cache and All in One SEO. My installation is Apache.

    Thanks beforehand,
    Nick

    Not sure if this will help anyone, but after a long 24 hrs of archiving 2014 and spinning up 2015 wordpress site, I couldn’t index with Google from webmaster tools. Kept getting the message that Google couldn’t access the robots.txt file. I’m using Google XML Sitemaps and have for several years with no problems. I’m on the latest version as of 1/25/2015. I could see the virtual robots file content and it was correct. I could directly access sitemap.xml through my browser and on Google Webmaster Tools.

    Anyway, the issue turned out to be the WP Maintenance Mode plugin as active. As soon as I made it inactive, everything started working. Ouch.

    Maybe this will help somebody, if they are using the WP Maintenance Mode plugin.

    It breaks completely the Google Webmaster Tool guidelines. Just 404 errors there!!!

    Update the newest version (replace it with the last worked version) or stop to offer it at the Wordpess site.

    I am getting a 404 error on my main sitemap index (www.website.com/sitemap.xml), however all other sub-sitemaps are listed and working correctly. Anyone encountered this before? Does this require amending .htaaccess file, rewrite rules or related to something else?

    Google Webmaster sitemap test also shows “General HTTP error: 404 not found HTTP Error: 404” for extension sitemap.xml, but works fine and recognises all other sitemap URLs.

    Server running on lighttpd.

    Many thanks in advance

    Hey folks, if you are using the iThemes Security plugin, that will cause a 404 error. In the ithemes security settings, I added /sitemap.xml to the 404 white list, as well as the exclusion list for the file change detection feature. Once I did those two things, I stopped getting a 404.

    Not sure if that’s everyone’s problem, but I hope it helps some of you.

    Hi, I have 21 websites all using the Google XML Sitemaps plugin. 4 of them give me a 404 error:

    “Not Found
    The requested URL /sitemap.xml was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.”

    I went through the checklist and everything was fine. My hosting company told me that “the sitemap wasn’t posting on the server side”

    Any help would be greatly appreciated. All of the 21 websites have identical plugins installed with all of the same settings. The servers are apache is there any server port setting that may be affecting this?

    I am using WP3 plugin and have tried deactivating it to see if it was causing the problem but it didn’t help. Please help. Thank you kindly, Joseph

    several my blog sitemap http://fastcars2.com/sitemap.xml show warning and error at webmaster guidelines, I was try fix the content on it but still error.

Viewing 15 replies - 31 through 45 (of 45 total)
  • The topic ‘404 File Not found? See here!’ is closed to new replies.