Support » Plugin: Google XML Sitemaps » 404 File Not found? See here!

  • Plugin Contributor Arne Brachhold


    In case you get an error that your sitemap file was not found, please follow these steps:

    1. Check your permalinks settings of WordPress and click the Save button
    2. If you are using nginx as a webserver, place add the Rewrite Rules manually. see here
    3. If you are using W3 Total Cache and activated the “Do not process 404 errors for static objects with WordPress” feature under “Browser Cache”, please add the rules stated below to the “404 error exception list”.
    4. If you have still problems, please post here.

    Rules for W3 Totacl Cache 404 error exception list:


Viewing 15 replies - 16 through 30 (of 45 total)
  • this is what i use in nginx and it works fine

    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml$ "/index.php?xml_sitemap=params=$2" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml\.gz$ "/index.php?xml_sitemap=params=$2;zip=true" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html$ "/index.php?xml_sitemap=params=$2;html=true" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html.gz$ "/index.php?xml_sitemap=params=$2;html=true;zip=true" last;

    I’m using version 4.0.5 on WP3.9.1/nginx and have set rewrite rules as namhuy posted, however, still having the 404 error.

    When I retrieve the sitemap from a browser, it is surely displayed, but the HTTP status code is 404.

    In my environment, HTTP status code is somehow 404 on line 1615 of sitemap-core.php. So, I have patched the plugin:

    *** sitemap-core.php.orig       2014-06-01 08:41:03.875005874 +0900
    --- sitemap-core.php    2014-06-01 08:40:33.483004966 +0900
    *** 1612,1617 ****
    --- 1612,1618 ----
                    if($html) {
                    } else {
    + header('HTTP/1.1 200'); // PiuLento
                            header('Content-Type: text/xml; charset=utf-8');

    Somehow, my 404 Error problem was fixed in version 4.0.6.

    In my case going from 4.0.5 to 4.0.6 made me get into 404 error… Therefore I had to revert to 4.0.5

    I was simply replacing all files via FTP. No settings in WP Dashboard were made. Reverting to 4.0.5 fixed the issue

    I will try other sitemap plugin if 404 error occurs again.


    Version 4 appears to be completely broken.

    Version 4.0.6 is broken for me as well. The sitemap files are simply never created.

    Reverted back to version 4.0.5 and same problem sadly. 🙁

    Debug log shows no errors. Looks fine. And yes still no sitemap files created at all.

    [autoSave:GoogleSitemapGeneratorStatus:private] => 1
    [_startTime] => 1402328896.7869
    [_endTime] => 1402328896.8432
    [_hasChanged] => 1
    [_memoryUsage] => 43778048
    [_lastPost] => 109
    [_lastTime] => 1402328896.8323
    [_usedXml] => 1
    [_xmlSuccess] => 1
    [_xmlPath] => /privatePath/sitemap.xml
    [_xmlUrl] =>
    [_usedZip] => 1
    [_zipSuccess] => 1
    [_zipPath] => /privatePath/sitemap.xml.gz
    [_zipUrl] =>
    [_usedGoogle] =>
    [_googleUrl] =>
    [_gooogleSuccess] =>
    [_googleStartTime] => 0
    [_googleEndTime] => 0
    [_usedMsn] =>
    [_msnUrl] =>
    [_msnSuccess] =>
    [_msnStartTime] => 0
    [_msnEndTime] => 0

    Running on WordPress 3.9.1 with PHP 5.5. Even tried with PHP 5.4 first.

    So reverted back to version 3.4.1 and working fine once again. It even correctly recreated the sitemap files as expected.

    However, after I re-enabled version 3.4.1 I got these “warnings”:

    The last run didn’t finish! Maybe you can raise the memory or time limit for PHP scripts.

    The last known memory usage of the script was 41.25MB, the limit of your server is 256M.

    The last known execution time of the script was 0.04 seconds, the limit of your server is 600 seconds.

    So I set “Try to increase the memory limit to: 64M” and then it worked just fine, as you can see below:

    Your sitemap was last built on June 9, 2014 3:48 pm.
    Your sitemap (zipped) was last built on June 9, 2014 3:48 pm.
    The building process took about 0.06 seconds to complete and used 41.75 MB of memory.

    So then tried version 4.0.6 and 4.0.5 once again. Same problem, xml files never created.

    Even tried to double memory limit to 128M to be sure.

    So seems version 4 is completely broken for me.



    Check your permalinks settings of WordPress and click the Save button

    It might be worth noting that if you are using the ‘Yoast WordPress SEO’-plugin you also have to update the permalink settings there (right sidebar -> SEO -> Permalinks -> Save).


    I have done a clean install of the plugin of the most recent version and requested the file be generated into

    I am unable to find the files using the cpanel file manager. The link in the plugin to the sitemap goes 404.

    The interesting thing is that you report:
    Google was successfully notified about changes.
    Bing was successfully notified about changes.

    XML Sitemap Generator for WordPress 4.0.7
    apache 2.2.27
    WordPress 3.9.1
    public_html/acl/ perms are 0755
    php 5.3.28
    OS linux
    mysql 5.1.67-rel14.3-log
    permalinks /%category%/%postname%/
    Override the base URL of the sitemap:
    host: Site5 Opinion: fair to middling

    Admin Management Xtended Version
    Akismet Version 3.0.0
    Dagon Design Sitemap Generator Version 3.17
    Exclude Pages from Navigation Version 1.92
    Flexi Pages Widget Version 1.6.13
    List category posts Version 0.48
    OptinMonster Version
    WooDojo Version 1.5.4
    WooSidebars Version 1.3.1
    WordPress SEO Version

    I’m not sure if I have a same issue or not. So, here it is:
    After installation, went to My Sites>>Network Admin>>Plugins and activate this plugin. Then, click in “Settings” and redirected to this page, which says “Page not found”.
    Here is further details:

    Word Press: V 3.9.1
    Google XML Sitemap: V 4.0.7
    Webserver: Apache (I think so)
    Theme: Brooklyn (Cache option is off)

    Thanks beforehand.

    In your instructions you say:

    “In case you get an error that your sitemap file was not found, please follow these steps:

    Check your permalinks settings of WordPress and click the Save button”

    What do you mean? Is there a special format for the permalinks to make this work?

    thelastcookie got me on the right track. I went into the Yoast SEO plugin and disabled the option to create the sitemap.xml. Looks like both plugins were stepping on each other. Works great now.

    I got a 404 as well. I installed XML Sitemap Generator for WordPress 4.0.7 instead and it works fine. So I think there is a problem with this plugin…

    My installation is somewhat pretty standard (apache 2, not nginx) and I am not using W3 Total Cache.

    I found all subsitemap pages are 404 in my sitemap.xml

    I am using 4.0.7 version



    I am having the same issue as most people above. I am getting a 404 when I try and locate my sitemap.xml. It just doesn’t look like one is being created. I have made all the checks and it still doesn’t work. I am using Godaddy as hosting (Linux). My webpage is in the root and there is no blog subfolder.

    Coton de Tulear Breeder – Pure Heaven Cotons

    is the website, any suggestions would be greatly appreciated.


    If you still can’t get your sitemap working after following the instructions, why not just downgrade to the 3.4.1 version that creates a static sitemap file? You can find the instructions here:

    I just did this as I wanted a static file rather than a set of dynamically generated files. (Other than this, the new version actually worked fine for me, I didn’t even need to add any rewrite rules despite being on NginX).

    After you’ve downgraded you can open the sitemap.php file in the google-sitemap-generator plugin folder and change the version number to something high. I used:
    Version: 9.4.1
    Below the comment block add:
    define('SM_NO_UPDATE', true);
    And this way you won’t get any notifications to upgrade.

    Remember that you’ll need to regenerate the sitemap from the plugin options after downgrading too.

Viewing 15 replies - 16 through 30 (of 45 total)
  • The topic ‘404 File Not found? See here!’ is closed to new replies.