WordPress.org

Forums

Google XML Sitemaps
404 File Not found? See here! (46 posts)

  1. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    In case you get an error that your sitemap file was not found, please follow these steps:

    1. Check your permalinks settings of WordPress and click the Save button
    2. If you are using nginx as a webserver, place add the Rewrite Rules manually. see here
    3. If you are using W3 Total Cache and activated the "Do not process 404 errors for static objects with WordPress" feature under "Browser Cache", please add the rules stated below to the "404 error exception list".
    4. If you have still problems, please post here.

    Rules for W3 Totacl Cache 404 error exception list:

    sitemap(-+([a-zA-Z0-9_-]+))?\.xml(.gz)?
    sitemap(-+([a-zA-Z0-9_-]+))?\.html(.gz)?

    https://wordpress.org/plugins/google-sitemap-generator/

  2. bookworm316
    Member
    Posted 1 year ago #

    I'm still having issue for now I'm going to revert to the older version unit things get flushed out more. Thanks for the help! http://www.bwone.com

  3. Arne Brachhold
    Member
    Plugin Author

    Posted 1 year ago #

    @Bookworm: You are using nginx and W3TC, so you would have to add the nginx rules as well as the settings for W3TC.

  4. bookworm316
    Member
    Posted 1 year ago #

    Hmm ok that's probably it then. I'll need to contact my hosting to make the change. I took a look on the page and I'm not sure which rewrite rules to give them.

  5. Gwyneth Llewelyn
    Member
    Posted 1 year ago #

    @bookworm316 — you should be fine with these:

    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml$ "/index.php?xml_sitemap=params=$2" last;
    	rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml\.gz$ "/index.php?xml_sitemap=params=$2;zip=true" last;
    	rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html$ "/index.php?xml_sitemap=params=$2;html=true" last;
    	rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html.gz$ "/index.php?xml_sitemap=params=$2;html=true;zip=true" last;
    	rewrite ^/robots\.txt$ "/index.php?robots=1" last;

    Ask them to add those after the location / { try_files ... } block or before any other rewrite rules you might already have.

  6. vio22
    Member
    Posted 1 year ago #

    I do not have the feature under "Browser Cache", activated..
    I also manually installed the plugin with no success.

    downtownchiropractor.ca is the site.

    Any help would be great!
    Thanks

  7. nitinbhatia123
    Member
    Posted 1 year ago #

    Hi,

    I am facing same issue for my blog http://www.nitinbhatia.in i submitted new sitemap yesterday with google and today i am getting "General HTTP error: 404 not found" for all 38 links submitted. Indexed URL is 0. I am using W3 Total cache and followed the step 3 as suggested. Resubmitted permalink. Pls suggest, there is drop in my blog traffic..Thanks in advance.

  8. dadobrado
    Member
    Posted 1 year ago #

    After submitting my sitemap to webmasters:
    General HTTP error: 404 not found
    0 URLs submitted

    I get this message on all of my websites. Followed steps for W3 total cache and it remained the same.

    Very dissapointing as this was the best XML plugin ever, and now, I am not so sure...

  9. Dge-06
    Member
    Posted 1 year ago #

    i've a same problem with the new version.

    Error 404 :(

    the link for rebuild the sitemap is no display.

    Update please !!

  10. Makio9
    Member
    Posted 1 year ago #

    Hello, about half my site is registering 404's and I also can't get the sitemap to say anything but "search engines haven't been notified yet".

    can somebody please assist.

    To resolve the 404's you can go to the dashboard, access the drafts and press update and your posts will come back. I'm more concerned as to why my sitemap isn't working

  11. Kramarz
    Member
    Posted 1 year ago #

    Broken here as well, RIP Google XML Sitemaps ?

    Try http://www.carlowgraphics.com/sitemap.xml and tell me how to fix it :-)

  12. carfuture
    Member
    Posted 1 year ago #

    Hi Kramarz, I have same problem with you.
    I try to delete old sitemap first (xml and gzip) then active and update the google xml sitemap new version, and its work.
    Now my blog sitemap look fine http://car2future.com/sitemap.xml

  13. wst8023
    Member
    Posted 1 year ago #

    404

  14. sibarita
    Member
    Posted 1 year ago #

    My server is Nginx.

    Add:

    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml$ "/index.php?xml_sitemap=params=$2" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml\.gz$ "/index.php?xml_sitemap=params=$2;zip=true" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html$ "/index.php?xml_sitemap=params=$2;html=true" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html.gz$ "/index.php?xml_sitemap=params=$2;html=true;zip=true" last;

    after: location / {

    But does not work. I get 404 error with sitemap-misc.xml

    Why??

  15. pruggera
    Member
    Posted 1 year ago #

    I get 404
    Operating System: Linux CentOS
    WordPress 3.5.2 with DB 22442 on PHP 5.2.17
    Plugin version: 4.0.4 ($Id: sitemap-loader.php 891809 2014-04-12 11:06:34Z arnee $)
    Site: couplescounselorsandiego.com
    SERVER_SOFTWARE = Apache

  16. tlienhart85@gmail.com
    Member
    Posted 1 year ago #

    My sitemap is not being updated by Bing, although it updates on Google every day. I clicked on XML Sitemap Generator and found at the bottom of the page that yesterday's sitemap report was sent to Bing at this address:

    http://www.bing.com/webmaster/ping.aspx?siteMap=http%3A%2F%2Fwww.envisionthepast.com%2Fsitemap.xml

    However, on the Bing Webmaster site, at the "Sitemaps" page, Bing instructs to use this address for "Pinging Bing Using a HTTP request"

    http://www.bing.com/ping?sitemap=http%3A%2F%2Fwww.example.com/sitemap.xml

    Are my Bing updates going to the wrong Bing address?

  17. namhuy
    Member
    Posted 1 year ago #

    this is what i use in nginx and it works fine

    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml$ "/index.php?xml_sitemap=params=$2" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.xml\.gz$ "/index.php?xml_sitemap=params=$2;zip=true" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html$ "/index.php?xml_sitemap=params=$2;html=true" last;
    rewrite ^/sitemap(-+([a-zA-Z0-9_-]+))?\.html.gz$ "/index.php?xml_sitemap=params=$2;html=true;zip=true" last;

    http://namhuy.net/sitemap.xml

  18. piu_lento
    Member
    Posted 1 year ago #

    I'm using version 4.0.5 on WP3.9.1/nginx and have set rewrite rules as namhuy posted, however, still having the 404 error.

    When I retrieve the sitemap from a browser, it is surely displayed, but the HTTP status code is 404.

    In my environment, HTTP status code is somehow 404 on line 1615 of sitemap-core.php. So, I have patched the plugin:

    *** sitemap-core.php.orig       2014-06-01 08:41:03.875005874 +0900
    --- sitemap-core.php    2014-06-01 08:40:33.483004966 +0900
    ***************
    *** 1612,1617 ****
    --- 1612,1618 ----
                    if($html) {
                            ob_start();
                    } else {
    + header('HTTP/1.1 200'); // PiuLento
                            header('Content-Type: text/xml; charset=utf-8');
                    }
  19. piu_lento
    Member
    Posted 1 year ago #

    Somehow, my 404 Error problem was fixed in version 4.0.6.

  20. Richard Vencu
    Member
    Posted 1 year ago #

    In my case going from 4.0.5 to 4.0.6 made me get into 404 error... Therefore I had to revert to 4.0.5

    I was simply replacing all files via FTP. No settings in WP Dashboard were made. Reverting to 4.0.5 fixed the issue

  21. piu_lento
    Member
    Posted 1 year ago #

    I will try other sitemap plugin if 404 error occurs again.

  22. war59312
    Member
    Posted 1 year ago #

    Hi,

    Version 4 appears to be completely broken.

    Version 4.0.6 is broken for me as well. The sitemap files are simply never created.

    Reverted back to version 4.0.5 and same problem sadly. :(

    Debug log shows no errors. Looks fine. And yes still no sitemap files created at all.

    [autoSave:GoogleSitemapGeneratorStatus:private] => 1
    [_startTime] => 1402328896.7869
    [_endTime] => 1402328896.8432
    [_hasChanged] => 1
    [_memoryUsage] => 43778048
    [_lastPost] => 109
    [_lastTime] => 1402328896.8323
    [_usedXml] => 1
    [_xmlSuccess] => 1
    [_xmlPath] => /privatePath/sitemap.xml
    [_xmlUrl] => https://www.mysite.com/sitemap.xml
    [_usedZip] => 1
    [_zipSuccess] => 1
    [_zipPath] => /privatePath/sitemap.xml.gz
    [_zipUrl] => https://www.mysite.com/sitemap.xml.gz
    [_usedGoogle] =>
    [_googleUrl] =>
    [_gooogleSuccess] =>
    [_googleStartTime] => 0
    [_googleEndTime] => 0
    [_usedMsn] =>
    [_msnUrl] =>
    [_msnSuccess] =>
    [_msnStartTime] => 0
    [_msnEndTime] => 0

    Running on WordPress 3.9.1 with PHP 5.5. Even tried with PHP 5.4 first.

    So reverted back to version 3.4.1 and working fine once again. It even correctly recreated the sitemap files as expected.

    However, after I re-enabled version 3.4.1 I got these "warnings":

    The last run didn't finish! Maybe you can raise the memory or time limit for PHP scripts.

    The last known memory usage of the script was 41.25MB, the limit of your server is 256M.

    The last known execution time of the script was 0.04 seconds, the limit of your server is 600 seconds.

    So I set "Try to increase the memory limit to: 64M" and then it worked just fine, as you can see below:

    Your sitemap was last built on June 9, 2014 3:48 pm.
    Your sitemap (zipped) was last built on June 9, 2014 3:48 pm.
    The building process took about 0.06 seconds to complete and used 41.75 MB of memory.

    So then tried version 4.0.6 and 4.0.5 once again. Same problem, xml files never created.

    Even tried to double memory limit to 128M to be sure.

    So seems version 4 is completely broken for me.

    Thanks,

    Will

  23. thelastcookie
    Member
    Posted 1 year ago #

    Check your permalinks settings of WordPress and click the Save button

    It might be worth noting that if you are using the 'Yoast WordPress SEO'-plugin you also have to update the permalink settings there (right sidebar -> SEO -> Permalinks -> Save).

  24. billunderwood
    Member
    Posted 1 year ago #

    site: http://aboutconsciousliving.com/

    I have done a clean install of the plugin of the most recent version and requested the file be generated into http://aboutconsciousliving.com/acl/sitemap.xml

    I am unable to find the files using the cpanel file manager. The link in the plugin to the sitemap goes 404.

    The interesting thing is that you report:
    Google was successfully notified about changes.
    Bing was successfully notified about changes.

    XML Sitemap Generator for WordPress 4.0.7
    apache 2.2.27
    WordPress 3.9.1
    public_html/acl/ perms are 0755
    php 5.3.28
    OS linux
    mysql 5.1.67-rel14.3-log
    permalinks /%category%/%postname%/
    Override the base URL of the sitemap: http://aboutconsciousliving.com/acl/
    host: Site5 Opinion: fair to middling

    Plugins
    Admin Management Xtended Version 2.3.9.2
    Akismet Version 3.0.0
    Dagon Design Sitemap Generator Version 3.17
    Exclude Pages from Navigation Version 1.92
    Flexi Pages Widget Version 1.6.13
    List category posts Version 0.48
    OptinMonster Version 1.2.7.2
    WooDojo Version 1.5.4
    WooSidebars Version 1.3.1
    WordPress SEO Version 1.5.3.3

  25. neo313
    Member
    Posted 1 year ago #

    Hi,
    I'm not sure if I have a same issue or not. So, here it is:
    After installation, went to My Sites>>Network Admin>>Plugins and activate this plugin. Then, click in "Settings" and redirected to this page, which says "Page not found".
    Here is further details:

    Word Press: V 3.9.1
    Google XML Sitemap: V 4.0.7
    Webserver: Apache (I think so)
    Theme: Brooklyn (Cache option is off)
    URL: http://www.themyth.com.au

    Thanks beforehand.
    Cheers,
    Neo

  26. universal1914
    Member
    Posted 1 year ago #

    In your instructions you say:

    "In case you get an error that your sitemap file was not found, please follow these steps:

    Check your permalinks settings of WordPress and click the Save button"

    What do you mean? Is there a special format for the permalinks to make this work?

  27. kapcreations
    Member
    Posted 1 year ago #

    thelastcookie got me on the right track. I went into the Yoast SEO plugin and disabled the option to create the sitemap.xml. Looks like both plugins were stepping on each other. Works great now.

  28. michel_roberge
    Member
    Posted 1 year ago #

    I got a 404 as well. I installed XML Sitemap Generator for WordPress 4.0.7 instead and it works fine. So I think there is a problem with this plugin...

    My installation is somewhat pretty standard (apache 2, not nginx) and I am not using W3 Total Cache.

  29. Amitpanwar
    Member
    Posted 11 months ago #

    I found all subsitemap pages are 404 in my sitemap.xml

    I am using 4.0.7 version

    URL: ipost.com/sitemap.xml

  30. metuckness
    Member
    Posted 11 months ago #

    Hi,

    I am having the same issue as most people above. I am getting a 404 when I try and locate my sitemap.xml. It just doesn't look like one is being created. I have made all the checks and it still doesn't work. I am using Godaddy as hosting (Linux). My webpage is in the root and there is no blog subfolder.

    http://pureheavencotons.com

    is the website, any suggestions would be greatly appreciated.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google XML Sitemaps
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags