WordPress.org

Forums

404 file not found, rss working (9 posts)

  1. GrendelS
    Member
    Posted 9 years ago #

    Hi,
    http://www.iroke.de/wp/ is new, seemed to be working, but the two posts don't show up. I disabled all plugins (didn't help or change the situation though), the rss is surprisingly working (http://www.iroke.de/wp/?feed=rss), and the permalinks feature has not been used yet.

    The path I set in general/options is http://www.iroke.de/wp

    I have a subdomain active on the same server (daad.iroke.de), could there be a problem with the apache setup&WP?
    ciao

    Grendel

  2. GrendelS
    Member
    Posted 9 years ago #

    update: I used these instructions to install WP:

    http://codex.wordpress.org/Installing_WordPress#Detailed_Instructions
    ...and didn't get any error message until I opened the main page

    I also checked the url in phpmyadin, the line read
    siteurl Y 1 http://www.iroke.de/wp
    which is correct I believe.

    I also looked at similar support requests, like
    http://wordpress.org/support/topic/33651
    but since I don't use permalinks, my problem seems to have a different reason.

  3. GrendelS
    Member
    Posted 9 years ago #

    I also tried to turn on permalinks - the 404 was still there, turning it off didn't have any impact as well.

  4. stchatterbox
    Member
    Posted 9 years ago #

    grendelS,
    i've tried to access your page. but there's only a 404 error page. it's not working. so did you modified your css or template files in any ways?

  5. GrendelS
    Member
    Posted 9 years ago #

    no, it's a standard installation. No changes whereever... I can't even recall an error message, I got through with the instalation process no prob (it's not that much anyway ;-) ). I'm almost thinking about deleting the whole thing and just reinstall it since there's no data in the db anyway, but if it happens again I'm back at square one and no clue what's going wrong.

  6. GrendelS
    Member
    Posted 9 years ago #

    btw, the mysql version is 3.23.58, php 4.3.10
    I'll try a reinstall.

    update: just did, same error on the mainsite, no error at all during install :-/

  7. GrendelS
    Member
    Posted 9 years ago #

    Alright, after eight reinstalls the guys in the irc channel were able to give the decisive hint: Switching over to the old theme, suddenly everything worked. The reason for the 404 with the new default theme was that it had a 404 page, the old one doesn't, i.e.
    http://www.iroke.de/wp/index.php
    worked all the time, but not
    http://www.iroke.de/wp/
    The reason for the index.php not showing up is a misconfiguration on my provider's side.
    Case closed, thx for reading (and helping!)

  8. GrendelS
    Member
    Posted 9 years ago #

    *argh*
    Case reopened. My provider can't confirm any error with the DirectoryIndex, so again, I have no clue what's wrong. They said it might be mod_rewrite, but the error existed before I enabled it. When using a template that doesn't have a 404 page, it works, but only on the surface. That something's still not right with the urls, take a look at the last but one button in the sidebar (w3c validation referrer button). Click it, and the validator won't find the page. Again, htaccess is renamed and disabled, permalinks not used.

  9. GrendelS
    Member
    Posted 9 years ago #

    I was able to get around the problem that the index page didn't show anything at all except a 404. While no template without a special 404 page will show the error, the link to the archives is b0rked as well. I commented out a part of the code from wp-blog-header.php
    // Process PATH_INFO and 404.
    and at least the start page showed up again. Now, never mind permalinks or not, the archives are not there.
    http://www.iroke.de/wp/2005/06/
    won't work while
    http://www.iroke.de/wp/
    works.
    Any hints are highly appreciated...

Topic Closed

This topic has been closed to new replies.

About this Topic