Support » Fixing WordPress » 404 file not found after log-in submit.

  • Not a new problem, but after reading posts I am still stuck. I am woking on a intranet and have a working MySQL with PHP IIS server on XP. Installation went as described until log-in. I can view main index and link around, but when I link to the log-in and enter admin/password and then get the 404 page not found. I have done all the suggested fixes I could find.
    1) cleared cookies. This lets the log-in page re-appear with the blank form. Fill it out, submit and back to 404. I have checked my cookies folder and there is a WP cookie with a string of random stuff.
    2) cleared temp cache. got a good chunk of my drive back, but no fix.
    3) In wp-login.php replaced $user_login = $user_data[‘user_login’]; with $user_login = $user_data->user_login; . Even downloaded and installed the updated wp_login.php file from rboren. Nope.
    4) Changed password via phpMyAdmin with a simple one that I hashed with http://bfl.rctek.com/tools/?tool=hasher.
    I have done all a couple of times.
    My final idea is that I noticed after submitting the admin/password the borwser url is: http://localhost/WPSite/wp-admin/ with the 404. wp-admin is a directory so it should load the index.php in it. The site does load http://localhost/WPSite/ with out a problem and I have checked the server config and it has index.php as a default document. So it shouldn’t be a server problem, but if there is a chance what I would like to try is making the sumit link explicit with the full http://localhost/WPSite/wp-admin/index.php but I am not very strong on php or the WP files to edit this. Otherwise I am lost, tired and hungry. Any ideas and help would be greatly appreciated. Thanks in advance.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I have the problem before exactely the same to yours. I was always type the index.php after wp-admin/ by myself. I still think it is a server problem, because after I changed my host, problem gone.
    I am not familiar with IIS. I host myself by Apache once. and I remenber that only index.html(htm) is a default page if you don’t set one. And the setting for index.php would not cover it’s sub-dir.

    I have checked the default files for the sub-folders and index.php is valid for them. As a test I threw together a quick site on ther server with a subfolder/index.php and added index.php as a default for that site and all worked as expected. I know this isn’t a server forum, but I ‘think’ it is not a server problem. Even adding the index.php after wp-admin/ isn’t doing it.
    Two additional items.
    1) When I tried the site this morning and tried to log-in, the 404 came up immediately. Deleteing the cookies and reload brought the form up. Is there something wrong with the cookie setup I can look for. Same problem with IE, Foxfire, Netscape.
    2) Loaded it on mac osX without a problem. Great when all goes right.
    I guess the next test is to reinstall on IIS and see if that works. I will report after I have a chance to do that. Thanks coolger.

    Reinstalled WP on the IIS server and this time it all worked. yeh! So did a full comparision of files between the two installs and beside the expected differences in siteurl and passwords found a difference in the cookie code in wp-includes/vars.php as mentioned in faq http://faq.wordpress.net/view.php?p=68. Updated the vars.php file and now the original is working.
    I think what happened is that I started with a server default files issue and while troubleshooting checked out the vars.php file and accidently made a small edit!? It was late. When I got the server all squared away, the cookie was broken. Both had the same effect when triing to login, so I was stumped.
    Thanks for the great program and now looking forward to messing around and posting to the plugins, hacks and design support lists!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘404 file not found after log-in submit.’ is closed to new replies.