Viewing 12 replies - 1 through 12 (of 12 total)
  • Moderator Bet Hannon

    (@bethannon1)

    Support Team

    So your main site is: http://waynefusco.com/w3/? That means you have installed a multisite network in a subdirectory. Right?

    But your classof79.waynefusco.com looks clearly like a subdomain site — not a subdirectory site.

    Is your multisite set up as a subdomain or a subdirectory type?

    Thread Starter WayneFusco

    (@waynefusco)

    I thought I set it up as a subdomain which is what I wanted to do.

    I read that you should not setup WordPress multisite in a root folder so I installed it in the /w3 folder.

    This is the multisite config
    /* Multisite */
    define( ‘WP_ALLOW_MULTISITE’, true );
    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, true);
    define(‘DOMAIN_CURRENT_SITE’, ‘waynefusco.com’);
    define(‘PATH_CURRENT_SITE’, ‘/w3/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);

    Moderator Bet Hannon

    (@bethannon1)

    Support Team

    Actually, for subdomain, you DO want to set it up in the root of the domain. Trying to do this from a subdirectory might be your problem.

    Do you have subdomain wildcards set up on this domain — and are you sure your host supports subdomain wildcards? And, you are letting the network set up the subdomains — you haven’t manually created classof79.waynefusco.com?

    Thread Starter WayneFusco

    (@waynefusco)

    Thanks for the help,

    Yes I have wildcards setup
    I am guessing it does – I am own cPanel and it, cPenel says it is (see screenshot)
    http://prntscr.com/mp8byn

    I am sorry, not sure what you mean by am I letting the network setup the subdomains. I set them up under sites –

    Moderator Bet Hannon

    (@bethannon1)

    Support Team

    Sometimes people try to add the subdomains manually in cPanel. It sounds like you are just setting them up in the network admin — that’s the only place you should need to set them up.

    Thread Starter WayneFusco

    (@waynefusco)

    So because this is brand new, should I delete the network install and reinstall in the root folder? It no big deal if I need to. There is only sub on it anyway.

    Thread Starter WayneFusco

    (@waynefusco)

    I want to start off on the right foot..

    Moderator Bet Hannon

    (@bethannon1)

    Support Team

    I think that will be easier than trying to make all the needed path changes in the db… especially since it’s a new install.

    Thread Starter WayneFusco

    (@waynefusco)

    So I reinstalled

    Did the network setup.
    Got a error that wildcard dns was not enabled for my domain – cPanel told me how to fix it.

    When I go to the dashboard of a site i added and get a 404 error. I can provide any info you need to help..

    Thank you

    Moderator Bet Hannon

    (@bethannon1)

    Support Team

    What is the url for your mainsite & the subsite that gives the 404?

    Where is this hosted?

    Thread Starter WayneFusco

    (@waynefusco)

    GOT It… It was the cPanel setup there was no directory associated with the wildcard domain.

    Thank you for all the pointers so far…

    How do I change the site url?
    its set to http://waynefusco.com and it should be https://www.waynefusco.com..

    Moderator Bet Hannon

    (@bethannon1)

    Support Team

    I think that you might want to just keep the non-www and add a snippet of code to your .htaccess to redirect www to non-www.

    This ought to work:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^www\.waynefusco\.com
    RewriteRule (.*) http://waynefusco.com/$1 [R=301,L]

    Or you could create a CNAME record in the domain zone file.

    It will be way easier to to one of those than change the site URL….

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘404 erros’ is closed to new replies.