Support » Fixing WordPress » 404 errors unless registered

  • Resolved Cherokee


    When searching previous posts, I get a 404 error that the post can not be found. I’ve discovered that this occurs only with post prior to February of this year (2008).

    Clicking on the permalink or on comments yields the message:

    Not Found

    Sorry, you are looking for something that isn’t here.

    If I am logged in, there is no problem. I’ve tried this with a test user as well. Not logged, 404 errors. Logged in, no problem.

    I’ve tried changing the Permalinks but get the same result no matter what form of Permalink I use. BTW, if you place the cursor over the post title, it will indicate what the link address is.

    My site is:

    Any ideas or clues will be greatly appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Forgot to mention, I’m running 2.5.1

    Finally solved it.

    I had merged a TypePad blog (by the same name) with this one. I migrated the posts in April of this year. When I finally figured out that things seemed to stop working at a certain date (February for some reason), I went to Manage > Posts, and started working my way backwards.

    What I found was that the status of numerous entries were missing. There was no Published status. Opening the post for editing showed Published on the top right, but the Save and Publish buttons were both available. If the post was really published already, there would only be a save button available.

    So, clicking on the Publish button fixed the issue. Now if I go to a post that has been fixed, the permalink works fine even if I’m not logged in.

    Of course, now I have to review posts going back to 2005. Thank goodness I wasn’t a daily poster.

    Hope this helps someone else.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘404 errors unless registered’ is closed to new replies.