Support » Plugin: SearchIQ - The Search Solution » 404 Errors regarding fonts/SIQ_icomoon.ttf?o72w6t

  • Hi. I love the plugin but am trying to chase down net::ERR_ABORTED 404 errors on all pages as I have the plugin short code embedded in my page header. Errors can be seen on page reference and are

    GET net::ERR_ABORTED 404

    which do reference a non-existent directory path. I deleted and reinstalled the plugin thinking that the directory somehow disappeared but reinstalling the plugin had no affect and I can not find such /fonts/SIQ_icomoon.ttf?o72w6t directory or file reference via ftp.

    Functionality appears not to be and issue (so far in testing).

    Thoughts on how to address these errors?

    Thank you

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 15 total)
  • Plugin Author SearchIQ


    @dt123 Thank you for contacting us. We are checking the mentioned issue and will update you soon.

    Plugin Author SearchIQ


    @dt123 We have checked your site and observed that you are using wp-fastest-cache plugin to cache the CSS. This plugin clubs all CSS files all the plugins into one single CSS file (
    And the CSS file that we add in our plugin to define the path of the fonts used for icons is getting added under a separate style tag causing the browser to look for fonts using the path mentioned in the CSS definition which is not there because the CSS has been moved out of its actual file. This is the reason for errors in browser.

    Thank you for the reply and it makes sense. Any known workarounds or is this a choice of on plugin over the other?

    Plugin Author SearchIQ


    @dt123 We can try for one solution. Please check if the caching plugin has some ignore list, then you can ignore this file.

    Thank you for the suggestion. I have been testing this and other alternatives. My findings are:

    1. Adding the exclusion into WP Fastest cache had no affect.
    2. Deleting the cache and deactivating the Fastest Cache plugin made no improvement and the errors still appears?

    All this said, there does not appear to be a performance issue with SIQ o I guess I will live with the errors being thrown for now.

    Thanks for your help

    One other item I have been struggling with and can make a new post if preferred.

    I have custom post which appear to be set and active in the configuration tab, but no custom posts are displayed in my search results or in the auto complete.

    Not much setup to trouble shoot.

    Ideas to try? Or is possibly related to the css issue and errors noted here?

    Thank you.

    Plugin Author SearchIQ


    @dt123 It’s great that all the features are working fine.
    Please share the URL for the custom posts that you are referring to so we can check.

    I only have a couple “published” posts right now and understand that “drafts” are not searchable (perfect). Bu the published posts here are not showing up n search results at or in auto complete when searching with words included in the posts.

    I have excluded several site pages, but not any of the posts, or custom posts. On settings I have the pages (searchable) and the posts / custom posts set to be searchable (yes) by default.

    Thank for taking a look.

    My apologies. It appears my issue above is resolved. Perhaps chache clearing of latency. Anyway let’s go ahead and close this ticket.

    Thanks for your assistance!

    Plugin Author SearchIQ


    @dt123 Ok, no worries. Please feel free to contact us for any query.
    If you liked the plugin, please leave us a positive review. Your kind words means a lot to us.

    Hi all. I would like to revisit this ticket as I am not trying to deal with site performance and have noted that their are several SIQ related issues pointed out using GTMetrix including: Optimize the order of styles and scripts, Avoid bad requests (the urls generated by wp fastest cache? – even thought the plugin was deactivated before running the GTmetrix test), and Avoid CSS @import.

    Looking at the waterfall report, these errors indicate that they are consuming around 2s of page load time!

    Not sure why 404 urls as still in play if they are due to fastest cache and would think they/issues with SIQ would go away with fastest cache deactivated. I now have w3 total cache running to see if I can use it with SIQ but have not figured it out.

    Any ideas on what to do next? Obviously I can’t have the 2s page load adds I am seeing with SIQ

    Ideas from here?

    Thank you

    Plugin Author SearchIQ


    @dt123 We are checking the mentioned issue and will update you soon.

    Plugin Author SearchIQ


    @dt123 We have checked and here are the observations.
    1. As per your message we have checked on Gtmetrix and there are no SearchIQ related issues under Optimize the order of styles and scripts and Avoid bad requests
    2. There is an issue related to Avoid CSS @import from SearchIQ but that would not have any effect on the site load speed.
    3. We checked the speed impact of SearchIQ on the site but could not see a 2 second difference. The site takes 3.01 seconds to load as per Gtmetrix and it is highly impossible for SearchIQ to take 2 out of 3 seconds. Please let us know how did you calculate 2 seconds difference.
    Here is Gtmetrix link for your reference.

    Hi and than you for the quick response. I did make some changes earlier this morning that resolve many of the issues I mentioned – sorry just getting back to update ticket now.

    The only other thing I could point out is that changing from WP Fastest Cache to W3 total cache seemed to make the difference, and the 404 errors I mentioned must have been a latency issue after switching caching plugins.

    Any suggestions regarding the avoid css @import? – Not a biggie right now.

    Thank you for your great plugin and support!

    Plugin Author SearchIQ


    @dt123 We will check to find the solution to avoid css @import. I’ll update you once done.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘404 Errors regarding fonts/SIQ_icomoon.ttf?o72w6t’ is closed to new replies.