WordPress.org

Forums

Custom Permalinks
404 errors only with certain links (3 posts)

  1. salvador21
    Member
    Posted 1 year ago #

    I am getting page errors for seemingly random permalinks. I am adding the extension html to permalinks as I am convering an old static html site and want to retain the same page URLs

    For example:

    I can happily name a page permalink to to aboutme-contact.html

    but if I then create a page aboutme-audiofiles.html then I get a 404

    If I change that page link something else, e.g. to aboutme-audiofiles-new.html all is fine again.

    Can anyone help please?

    http://wordpress.org/plugins/custom-permalinks/

  2. Weve
    Member
    Posted 1 year ago #

    Hello,
    I don't know if it will help but I worked on websites with the same configuration of yours and I noticed that permalinks were recorded into the database as a post_meta linked to a post ID. The thing is that Custom permalinks records twice the same information : one for the post Id, one for the last post revision ID. So, try to disable post revision feature may help you solve the problem.

    Put this line in your wp-config.php :
    define('WP_POST_REVISIONS', false);

    Bye

  3. salvador21
    Member
    Posted 1 year ago #

    Many thanks, but I have now got a round this another way using a different plugin which seems a lot simpler in that its function is to do nothing else except add .html

    So far it has been OK, but I am slightly sceptical about anything which will alter URLs, redirects etc. until a really through road test.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Custom Permalinks
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic