WordPress.org

Forums

404 Errors on Permalinks (8 posts)

  1. jhubb
    Member
    Posted 9 years ago #

    When I turn permalinks on, clicking on a post title returns a 404 Page Not Found error.

    I've read "Using Permalinks" on the codex and reviewed similar posts here in the forums, but I still can't get them going. I must be missing something... Here's what I've tried:

    1) CHMODed the .htaccess file to 666
    2) Changed SERVER_SOFTWARE variable in vars.php as instructed in the codex
    3) Contacted my host about the AllowOverride function and didn't get much help. I think this is probably where the issues resides.

    I can't find an httpd.config file on my server, but my host insists I can change the AllowOverride function in .htaccess. Their support provided me with the following links, but not being one for coding, it's all greek to me:

    http://apache-server.com/tutorials/ATusing-htaccess.html
    http://httpd.apache.org/docs/mod/core.html#allowoverride

    Can anyone tell me what needs to be done to the .htacess file to AllowOverride? Or is my host mistaken, and do I really need to modify the httpd.config file (my suspicion)?

    Thanks!

  2. Class
    Member
    Posted 9 years ago #

    I had to edit the httpd.conf for permalinks to work for me, not sure why but nothing else worked.

  3. jhubb
    Member
    Posted 9 years ago #

    Where did you get ahold of the httpd.conf file? I can't find one on my server... I'm assuming the host has control of this file but they don't seem to want to edit it for me... :(

    PS - I tried adding

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    to the .htaccess file and it brought the whole site down with a 500 Internal Server error.

    And if it makes a difference, I'm using a modified Kubric theme.

  4. Class
    Member
    Posted 9 years ago #

    httpd.conf is in /etc/httpd/conf on my host (fedora based).
    Usually this is shared for all users on a shared host and maybe that's why they won't edit it.

  5. jhubb
    Member
    Posted 9 years ago #

    Thanks... no such file in my etc folder... I do not have a dedicated server so maybe you are correct... however they should be able to do the AllowOverride for just my directory on the server... no?

  6. Class
    Member
    Posted 9 years ago #

    AFAIK, it should be possible with override but I never got it working for some reason.
    This might be a obscure bug/feature because I only found one other having the same problem that I had here in the forums, this person also had to edit the main server config to get it working.

  7. ErrantFool
    Member
    Posted 9 years ago #

    I'm having the same issue. I'm using Laughing Squid for hosting. I don't seem to have access to that httpd.conf file.

    Any other ideas?

    FYI, my categories come up fine but none of the posts do.

    Thanks.

  8. ErrantFool, make sure that your .htaccess file is set to permissions 666 (CHMOD 666). There are a few prominent WP users who are hosted on Laughing Squid, and WP's lead developer is one of them. I have heard of no problems with LS.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags