Support » Plugin: WordPress Email Template Designer - WP HTML Mail » 404 errors on latest version – breaking settings area

  • Resolved lukeseager

    (@lukeseager)


    I use this plugin on almost all websites I build for clients, and 99% of the time, it’s great!

    I do have an issue with the latest version for one client though, I’m getting 404 errors for the below assets:
    /wp-includes/js/dist/escape-html.min.js?ver=4198c7c0e05a9f34f4126334be746ddd
    /wp-content/plugins/wp-html-mail//css/style.css?ver=3.0
    /wp-content/plugins/wp-html-mail/js/template-designer/dist/main.js?ver=b3cb2da06d2e53dccd13e6b343fdd641
    /wp-includes/js/dist/html-entities.min.js?ver=81efc2ce02f13b864d66666c7bec2136
    /wp-content/plugins/wp-html-mail//js/admin_script.js?ver=3.0
    /wp-includes/js/dist/escape-html.min.js?ver=4198c7c0e05a9f34f4126334be746ddd
    /wp-includes/js/dist/html-entities.min.js?ver=81efc2ce02f13b864d66666c7bec2136
    /wp-content/plugins/wp-html-mail/js/template-designer/dist/main.js?ver=b3cb2da06d2e53dccd13e6b343fdd641
    /wp-content/plugins/wp-html-mail//js/admin_script.js?ver=3.0
    /wp-content/plugins/wp-html-mail//css/style.css?ver=3.0

    Some of the files are duplicated, not sure why, but I get a console message of “Failed to load resource: the server responded with a status of 404 (Not Found)” with all of those assets. If I switch back to the old wp html email editor, it still doesn’t work because the main.js file can’t be found.

    Without these files, the settings page is pretty useless unfortunately.

    The website is on a Windows server, PHP 7.4.4, the WP 5.4.1, with the classic editor plugin installed and set to allow users to switch (incase that makes any difference!). Site health mentions that exif and imagick modules are unavailable.

    • This topic was modified 1 month, 2 weeks ago by lukeseager.
    • This topic was modified 1 month, 2 weeks ago by lukeseager.
Viewing 1 replies (of 1 total)
  • Can you manually check whether or not the files exist. If the files do not exist try to delete and reinstall the plugin. Your settings should be save in your database.
    best regards, Hannes

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.