Support » Themes and Templates » 404 errors and custom post types don't use their archive pages

  • This is driving me _up the wall_ and I really need help.

    I keep getting 404 errors for my custom post types when I use permalinks. I have: reset the permalinks, tried the flush rewrite, tried resetting my local….nuked my database. Everything.

    On top of it, if its not 404-ing, its just using the index template rather than an archive template.

    Nothing. Works. It will not use archive-books.php, it will ALWAYS default to index.php. my other post types, just 404, all the time.

    Here’s my code:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    What am I doing wrong?

    the other thing…I can not for the life of me get the rewrite to work on taxonomies. Basically If i have /[post-type]/[taxonomy]/[term] …I just want the taxonomy part in the URL to go away. with_front => false does not work when I try it. Other methods I’ve tried, do not work. I am at a loss.

    Any help would be greatly appreciated, I am pulling my hair out at this point.



  • The topic ‘404 errors and custom post types don't use their archive pages’ is closed to new replies.