Support » Installing WordPress » 404 error,500 Internal Server Error & Fatal error: Out of memory in my wp!!

  • Hello,
    I moved my site from an American server to a European and since then when I open multiple pages from my site separately, example: 16 pages all opened the same time or sometimes when I upload external media or when I upload a photo to a post i get this message:

    1.”Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.”

    3. I get a Fatal Error messages. Some examples are dispalyed below.

    Fatal error: Out of memory (allocated 11534336) (tried to allocate 30720 bytes) in /home/site/public_html/ on line 1412

    Fatal error: Out of memory (allocated 36175872) (tried to allocate 76 bytes) in /home/site/public_html/ on line 43

    4. Also there are times that I click on page and when it loads it says that the page doesn’t exist, this also happens when I create a post.

    i have “memory_limit = 256M”
    19 activated plugins
    and in my .htaccess this:

    suPHP_ConfigPath /home/site/public_html/
    # BEGIN Better WP Security
    # END Better WP Security
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    Does anybody know what all of these mean? and how i can fix it?!

Viewing 15 replies - 1 through 15 (of 22 total)
  • MichaelH provided the “official list” nearly a year ago in this post

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don’t have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define(‘WP_MEMORY_LIMIT’, ’64M’);

    4. Talk to your host.

    If you see my post above you will see that I have more php memory. I tried the mark 3 and I think the problems with the “Fatal error: Out of memory” but I still keep having “404 Error” and “500 Internal Server Error”…

    Your post indicates you are sometimes dying on less than 12MB of memory:
    Out of memory (allocated 11534336)

    500 errors can also be the indirect result of memory errors, as they often indicate the “task” was canceled by your host’s automated “process killer”.

    This is your host problem

    maybe they fixed 500 Internal Server Error but now it started to have every time that i try to enable some plugin or upload image or video in a post..

    503 Service Unavailable
    The server is temporarily busy, try again later!
    Powered By LiteSpeed Web Server
    LiteSpeed Technologies is not responsible for administration and contents of this web site!


    Even a casual search of “503” in this support forum indicates that a 503 is “always” an indication that your web hosting is not working properly: overloaded or some parameter or other not set big enough to handle all the usage of all their customers. More details on a 503 here:

    My advice is to find a new web hosting company, and try and get a refund from this one.

    It just took 3-5 minutes to get your host’s home page to respond. If they can’t even get their own site to respond, they are hardly capable of providing reliable fast service to their customers.

    This confirms my previous advice: move to another web host.

    @adiat Arbers?

    Yes, Arbers. I just tested it again and their home page is still painfully slow.

    @adiant, thanks, what kind pipe are you on? maybe it is the chat? we are using wp supercache too

    I am on “Broadband 100” with 100Mbps download and 5Mbps upload. I tested other sites at the same time as I was waiting for Arbers, and they all responded more or less instantly.

    I found that a free account on really opened my eyes as to what my site visitors were seeing, in terms of response time.

    So you really didn’t goto the site? You just did a Pingdom test?

    No, I tested from my browser at home. Typing

    @ourweb Yes I tried it too and it is too slow.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘404 error,500 Internal Server Error & Fatal error: Out of memory in my wp!!’ is closed to new replies.