WordPress.org

Support

Support » Localhost Installs » 404 error with all but home page

404 error with all but home page

  • Arterus
    Member

    @arterus

    Hi everyone,

    Firstly let me say I know there’s another post a few below this one with the same problem. Why start a new one?

    Well..

    I am totally new to all this, I have been struggling to even get this all set up at all, but I have managed to get WordPress working on my localhost. I am using WAMP, and as far as I know as a beginner everything is ok.

    Except that I get 404 error whenever I make a new page. (the default setting on permalinks is the only one that works)

    I started a new thread because the one below, talking about htaccess and rewrites is completely above my head. I don’t even know what they are… Sorry.

    So, the good news is this seems to be a common problem, the bad news is I need spoon feeding info on how to fix it. I don’t mind learning some new stuff along the way (of course I have to know ‘what’ to learn) so please direct me to other documents if you think it may help me overall.

    Thanks for helping a newb out.

    Art.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Sisir
    Participant

    @prionkor

    I made a post while ago how to solve this problem. Let me know if this works for you.

    http://quickhow.net/2012/code/how-to-fix-wordpress-404-permalink-error-on-localhost

    Let me know if you don’t understand it. I will try to help 🙂

    Karun
    Member

    @karunshakya45

    Go to setting and select permalink and choose default and save the setting. You problem will be solved.

    Arterus
    Member

    @arterus

    Morning folks,

    Prionkor, thank you.. This seems to have solved the issue.

    Being a person who likes to learn about such things as I go… Can you give me a brief, and dumb ‘reason’ as to why that works please?

    @karunshakya45: Thanks for the suggestion, but as you can see from my original post ‘(default setting on permalinks is the only one that works)’ I already know this is a solution.. However I don’t want my pages to be named in PHP, so I am looking to solve the problem once and for all.

    Thanks all,

    Art

    Sisir
    Participant

    @prionkor

    Hello,

    Pretty permalink requires mod_rewrite to be enabled. If mod_rewrite off server can’t redirect ugly urls like http://yoursite.com?tag=test to http://yoursite.com/tag/test/

    Related Read:

    http://en.wikipedia.org/wiki/Rewrite_engine
    http://httpd.apache.org/docs/current/mod/mod_rewrite.html

    Hope it helps.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘404 error with all but home page’ is closed to new replies.