Support » Plugin: Participants Database » 404 Error when using Sign-up shortcode

  • Resolved AlbertJPeters


    As you may have noticed by now, I’ve become a fan and contributor to your efforts. Love the PARTICIPANTS DATABASE plugin, although I’m having a problem.

    When starting my test cycle for the form I’m planning, things seemed normal. However, something has caused a derailment. I get:

    404 — Fancy meeting you here! …

    This now happens when I press SUBMIT on a correctly completed form.
    It also happens when I miss one or more of the required fields on the form. Submission and content checking both worked previously (although I’ve made form revisions since) and leaving out a required field generated the appropriate red box.

    I tried trashing the page and creating a new one. I also tried deactivating and reactivating the Plugin.

    The problem occurs under admin login, or anything less. I don’t take subscriptions to the site, and inputting the form may be a customer’s only use of the wordpress-based portion of my site.

    In my setup, I do not send an email to the “subscriber”. Their input serves our editor as a source of database information that the editor manipulates thereafter. I use a child theme of RESPONSIVE that contains only simple CSS augmentations…these seemed to work before.

    I’ll send email to you if you need URLs, etc…. Please just let me know.

    Many thanks….
    Al Peters

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author xnau webdesign


    Have you tried re-saving your permalinks settings to rebuild permalinks?

    Yes. My permalinks are set at default, and I re-saved. Can I show you anything that might “click” with you on the reason for the problem? Perhaps you could go to it ( try the form to see what I mean….

    Or – any other ideas?

    Al Peters

    Plugin Author xnau webdesign


    OK, the usual reason for this is the page request is getting stopped by a security filter. This is put in place by your web host using an Apache module named “mod_security”

    I suspect the word “request” (used in your submit button) is triggering it. Try removing that word and see if it helps.

    If that doesn’t do it, contact your web host about the problem and ask them if mod_security might be blocking your POST requests.

    This will have nothing to do with your theme or the CSS.

    I tried your chage – took out the word “request” from both the button and the name of the page. Doesn’t seem to help.

    I’ll contact my provider, NETWORK SOLUTIONS. But if it’s a problem with an APACHE module, I’m having trouble understanding why it worked previously, but stopped working. As if I did something in customization that caused it to stop working……

    If you think of anything else, let me know. Meanwhile I’ll contact my guys….


    Plugin Author xnau webdesign


    There is no visible why it wouldn’t work. I know it’s in the POST array because the link is correct, but you get the 404 if you try the link with the POST request. That tells me the server is dong something different with that request behind the scenes.

    The word “request” was just a guess because that could be considered a sensitive word…I didn’t see anything else that would trigger a security response. You web host will have a record of any security exceptions caused by your code.

    I figured you changed the wording of the submit button and that’s what broke it. What did you change between it working and not?

    I can’t recall if I modified any other settings that might account for the problem. I think the easiest course of action will be for me to start from scratch. I can certainly apply what I’ve retained in my notes about how I wanted to structure the database and such.

    I’ll leave SUBMIT alone….. And double check for other possible problem wording.

    I’ll drop another line when I’ve done these….please keep this open for the moment. I’ll be back!

    Many thanks.


    I think I’m ALMOST home. I put my submit button back to its original setting and cleaned up my submission form. I can fill out a sample form completely and send it, and get the listing into the database and the email notification of new subscriber gets sent.

    My one remaining problem seems to be error-checking. When I first installed plugin, failure to fill in a required field on the form resulted in that red-bordered box that listed the required fields left empty. NOW, if ANY required information is left off the form, I get the “404 message”.

    I MISS the red box, and I’m afraid that exhibitors missing a required field will too!

    Your thoughts?

    Plugin Author xnau webdesign


    I think I’ll need to see that. It’s probably the same thing…which I think we never figured out. If you want to keep it private, send me a link by email: support AT

    The link is off to you, with thanks.



    Thanks so much for not only your great plugin, but also for the thoughtful support you provided as we were working out the kinks.

    With you input, I gave WordPress a “clean” installation and was able to get the plugin going just fine. Great answer to the needs we had. I also learned a lot more about how WordPress works.

    Thanks again.


    Plugin Author xnau webdesign


    Glad to hear you got it working. That was a tricky problem.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘404 Error when using Sign-up shortcode’ is closed to new replies.