Support » Fixing WordPress » 404 Error when trying to preview, save draft or publish new post

  • I keep getting a 404 Error when trying to preview, save draft or publish new post. I have tried this with all plugins disabled – same result. I notice that the draft actually does get saved, but I found that by clicking on the Posts link. When opening those drafts and trying to preview them the result is 404.

    So I keep trying to add this as a new post. I delete the previously saved drafts. I also notice that sometimes when adding the title the post is saved and a permalink is generated – the proper permalink that matches my settings. But sometimes the draft isn’t auto-saved and the permalink is not generated, at least not visibly. This is a random symptom.

    I am running 3.1.1 (current version) and Thesis 1.8, all plugins and theme completely upgraded.

    I tried just putting the title in and previewing – that worked okay, but when I added my content (copied and pasted from Notepad++) which is only 200 words long, the save and preview and publish return the 404 error again.

    So I tried this AGAIN with the default and the Twenty-Ten theme – same results.

    It turns out this same issue happens with pages as well.

Viewing 15 replies - 1 through 15 (of 17 total)
  • Following up I checked database and cPanel says all good, but I ran the repair anyway. No change. I deleted javascript callout in the body text used with “transpose email” plugin and the preview then worked fine.

    I use that javascript call all over the blog so why, how, does that become an issue?

    I am having the same problem. Editing and adding new entries would result to a 404 error regardless of the theme.

    Wow, this is weird. It was working earlier after I posted the above and after 3 tries, I am getting the error again. Help.

    I’m experiencing the same issue. Need help!

    @mistermist and @ddavisphoto – are you using any javascript?

    I fixed my issue on that one post by deleting line by line until I discovered it was the Transpose Email js code. But I have had no issues with it on any other blogs.

    Also, I determined that if I try a New Post and add content first, then the title, the error occurs but the draft isn’t saved.

    I still think it might be a javascript issue, but if yo folks determine it’s a word or phrase that hags you up, please post the details here.
    This is the JS I am using – again, it works fine elsewhere on the site and many other sites.

    <a href="javascript:Transpose_Email('sponsors','','Info on Being a Sponsor Or Exhibitor') ">email us.</a>

    I’m not getting the 404 anymore. I didn’t do anything, I just left it for a day and it just worked.

    Though at first I did noticed the instance when it did not auto-save the post when creating/editing a post and then published/saved it immediately. That was when I used to get it. I wasn’t able to disable plugins one-by-one or remove JS so I really wasn’t able to investigate more.

    I am just glad that it works as expected now.

    @bartgragg, though that transpose email JS is good to avoid scrapers. Might use it. Thanks for the input.

    @mistermist – I just tried it again after your post above with nothing but the JS and it worked fine. No hesitations, nothing.

    Then I tried it with extra text – again, no issues. I even tried it by saving the title first, then by placing text and JS in the body before typing a title.

    No issues, and, like you, I had done nothing. No upgrades, no DB repairs, nothing.

    An absolute mystery.

    But I am glad it works because I am pretty sure that Transpose Email thing works… we’ve had email links up for a year now and no spam.



    I am also getting a 404 Error message when I click on the home page tabs to the other pages. I don’t understand what I did. I don’t believe I did anything because all I do is make posts on my blog. It is weird. Any suggestions anyone.

    I’m getting the error again. This is definitely a mistery.

    I’ve been getting this error a lot and have tried all the mod_security fixes. When I check my server error log, I find dozens of entries like this:

    [Sat Mar 17 21:55:50 2012] [error] [client] File does not exist: /home/<domain-name>/public_html/wp-admin/wp-content, referer: http://<domain-name>/wp-admin/network/index.php

    Moderator kmessinger


    @victor Font
    Posting to someone else’s thread, especially one that is 8 months+ old will not do you a lot of good.

    Please start your own thread. I also see in all the postings you have made not once did you post your url. Please, for you and anyone else reading this tread, post your url! That way we can see the source code, the theme, the style sheets, etc.


    I respectfully disagree on both points –
    Keeping a thread running until we find out what the issue is – you may have noted this has not been totally resolved – is a quicker way to find an answer than having to search multiple posts which may or may not have the correct terms in it. In this thread we get to gather all of the ideas and attempts people have at trying to resolve the issue. We get to gather data more efficiently.

    Normally I would say that posting the URL would help – In THIS instance looking at source code won’t tell you anything because the post doesn’t get posted therefor the code isn’t visible.

    Moderator kmessinger


    @really Must I

    Posting your own topic is smiled upon. Unless you’re having 100% without any doubts or variation, the exact same problem, do not post in someone else’s thread. Make your own.

    Posting to a tread 8 months old will result in a lot of people not seeing it. If they just check their profile for answers, after 8 months it will be at least 4 or 5 pages back if they do a lot of helping out.

    Posting the url helps in all cases. It lets us, if necessary, to compare with other’s having the problem all the code, what the theme is, plugins, etc. It lets us check the code for basic errors that might contribute to the problem. Also many of the folks helping out look for treads that have only 1 post as that means they have not been resolved.

    After 8 months are you still having a problem? Most older threads like this have been solved one way or the other. You can keep it alive by all means but I have noticed that after 4 or 5 users chime in with problems, the tread doesn’t get a lot of help from the volunteers here.

    @victor is evidently still having the problem.

    Just did a Forums search on 404 Error on Preview – THIS thread comes up second in line.

    And I am the one that started the thread.

    DO YOU HAVE A SOLUTION or are you just going to gripe at other people?

    Moderator kmessinger


    Just did a Forums search on 404 Error on Preview – THIS thread comes up second in line.

    That has nothing to do with how the volunteers here look for threads to help with. And that is what I was explaining to Victor. If you want to look through old threads for a solution fine but if you want help with a current problem and you start a thread, that will put you number one on the list. The “No Replies” filter is often used by folk to find questions to answer next.

    And I am the one that started the thread.

    I think you might be referring to this, which I was using to show why Victor Font should start his own discussion. The fact that you were the op had nothing to do with what I told Victor.

    After 8 months are you still having a problem?

    Was there an answer in your reply? I hope you got the problem solved.

    DO YOU HAVE A SOLUTION or are you just going to gripe at other people?

    My post was not meant to gripe but just to explain to you, as you disagreed, why I posted my remarks to Victor Font. Frankly, I don’t care if you agree or disagree. My comments were to assist Victor Font and they stand correct as posted.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘404 Error when trying to preview, save draft or publish new post’ is closed to new replies.