WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » 404 Error when trying to create a sitemap

404 Error when trying to create a sitemap

Viewing 15 replies - 1 through 15 (of 21 total)
  • Greetings,

    I was trying to locate the sitefile and to view it with SEO tools and when I click on the button where it says you can find your xml sitemap here I too get a 404 error and brings me to my hosting 404 error page.
    The directory it is pointing to is correct for wordpress’s location but there is no file called sitemap_index.xml. I also tried updating a post with viewing some of the nifty SEO tools in each post now. Awesome.

    1 other question, if we put in a keyword such as heart when we were speaking of 3-d and 4-d heart clips and the whole theme of the blog and site is aboput congenital heart defects and when I pull up the script from view source when I am viewing the post — should I see a Keyword meta tag for heart? Or is this just to check to see if I am using enough of the word heart in the post itself? Also, the title I see has the sites name twice back to back

    <title>First-ever 3-D Stress Map of Developing Embryonic Heart Sheds Light on Why Defects Form - Joseph's JourneyJoseph's Journey</title> How do I stop this from being doubled with no space?

    my site is: Joseph’s Journey and the post I updated is: First ever 3-d stress map

    Thanks for helping.

    Joseph

    I am also having this issue. Just installed the lastest version and clicking on the XML Sitemap button. Do you have to publish a post for it to create the sitemap? That file does not exist.

    well at least im not the only one with this problem. i have had to resort to using external sitemap generators as im not getting any answeres here. please someone help

    I am also having problems on several sites. I hope someone fines an answer soon.

    Same problem here. The page actually displays a sitemap below the 404 error on my page … weird. But Google still tells me there’s an error.

    A fix would be awesome

    See this post

    http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-fix-for-sitemap_indexxml-404-error?replies=30

    I was able to fix both sitemap & news site map on my one site.

    I consider this a band aid rather than a fix.

    See this post

    http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-fix-for-sitemap_indexxml-404-error?replies=30

    I was able to fix both sitemap & news site map on my one site.

    I consider this a band aid rather than a fix.

    I was hoping the above would work, but I must be the unlucky one. When I click on you can find your xml sitemap here the button that follows this statement, it still brings me to a 404. The file it is pointing to as well is not named sitemap.xml but the following

    ‘http://serverdirectory/wordpressdirectory/sitemap_index.xml

    Not sure why, but the above fix err bandaid didn’t work. Thank you so much for sharing though dmiyares.

    Joseph

    mines working now. 🙂

    what servers are you all running and do you have your own custom permalinks

    Why does the developer himself not answer to all these questions!? I do have the same problem, but not all sitemaps show 404 errors, just the post-sitemap.xml.

    Same for me. All of sitemaps getting 404, soon after upgrade to 3.5.1, even if I don’t know if is related to.
    Tried to save again sitemaps settings, and permalinks settings, no way.
    This is not the first time, after upgrades doesn’t worked so many times. Yoast sitemaps are no good, and I think Yoast should fix once and for all.
    I never deleted the excellent Google sitemap for this reason, although I would, because Yoast’s sitemaps are not entirely reliable, and you need to control them often, and always after some change.

    Try to create a new post and publish it. Then check the sitemap. In my case the new post appears, but NO old post. Seems like SEO does not check old posts and pack them into sitemap – at the moment just NEW posts are recognized.

    I published a new post 2 days ago, and it’s not a problem of new or old posts. I can’t check maps, because maps aren’t visible. Maps are created, the problem is that they are not where they should be, at /sitemap_index.xml. They aren’t incomplete or things like that, they are 404, not found.
    And this isn’t the first time.

    You do know that these files are not really created, don’t you? It’s virtual. No real files.

    My WordPress Blog is just part of my website, see Joseph’s Journey for visual of our main site. Since wordpress is not in the root directory but a subdirectory — could it be the reason sitemaps are not working. I tried everything, even the numerous pugins deactivating all, but it still does the same thing nadda, nothing but a 404…

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘404 Error when trying to create a sitemap’ is closed to new replies.
Skip to toolbar