Support » Networking WordPress » 404 error when trying to access new subdomain dashboard on WP multisite

  • Laurence

    (@laurencedawson)


    I recently followed an Elementor video tutorial to convert a single page website to a multisite (this included changes to wp-config and htaccess php files). Although the subdomain business.tonus.coach appears in the Network dashboard, I get a 404 error when trying to access the subdomain dashboard. I have limited knowledge of WP. Any assistance would be much appreciated.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hi @laurencedawson

    I’m sorry to hear that you’re having trouble with your WordPress multisite installation. You can take a few steps to troubleshoot this issue and get your site up and running again.

    1. First, ensure your server is configured correctly to support multisite. This requires the mod_rewrite Apache module to be installed and enabled. Additionally, your WordPress installation must be in a directory served by the Apache web server and not in a subdirectory of another site.

    2. Next, check your .htaccess file to ensure that the mod_rewrite rules for multisite are correctly configured. The .htaccess file should contain a block of code similar to the following:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    3. Check your WordPress site’s general settings to ensure that the site address (URL) is correct. Go to the “General Settings” page in the WordPress dashboard and make sure that the “Site Address (URL)” field is set to the correct URL for your multisite network.

    4. If you’re still having trouble, you might want to try re-enabling the multisite feature. To do this, you’ll need to:

    – Comment out the line that defines MULTISITE in your wp-config.php file (it should look like /* define('MULTISITE', true); */)
    – Delete the .htaccess file from your WordPress installation directory
    – Go to the “Tools > Network Setup” page in the WordPress dashboard and follow the prompts to re-enable multisite

    I hope this helps! Let me know if you have any other questions.`

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.