Support » Localhost Installs » 404 error when tried on localhost ubuntu

  • Resolved johnyc


    I’ve setup multisite wp on ubuntu server. I can see homepage & wp-admin console/dashboard. All other pages are giving 404 errors.
    I searched on the support forums & found the solution but & I tried to change /etc/apache2/sites-available/default file but no success.

    <VirtualHost *:80>
    	ServerAdmin webmaster@localhost
    	DocumentRoot /var/www
    	<Directory />
    		Options FollowSymLinks
    		AllowOverride None
    	<Directory /var/www/>
    		Options Indexes FollowSymLinks MultiViews
    		AllowOverride None
    		Order allow,deny
    		allow from all
    	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    	<Directory "/usr/lib/cgi-bin">
    		AllowOverride None
    		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    		Order allow,deny
    		Allow from all
    	ErrorLog /var/log/apache2/error.log
    	# Possible values include: debug, info, notice, warn, error, crit,
    	# alert, emerg.
    	LogLevel warn
    	CustomLog /var/log/apache2/access.log combined
        Alias /doc/ "/usr/share/doc/"
        <Directory "/usr/share/doc/">
            Options Indexes MultiViews FollowSymLinks
            AllowOverride None
            Order deny,allow
            Deny from all
            Allow from ::1/128

    I changed AllowOverride All from None & added ‘fileinfo option’ but know success.
    Kindly help me getting this done.

    Thank you.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Ipstenu (Mika Epstein)


    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    Can you see pretty permalinks on your main site?



    Thank you @ipstenu
    wow! when I change parmalinks to default ‘/?p=3’
    it works. other custom options doesnt work.

    haha funny! why it’s so?
    Issue resolved.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘404 error when tried on localhost ubuntu’ is closed to new replies.