Support » Plugin: Awesome Surveys » 404 Error when submitting

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Will Brubaker

    (@willthewebmechanic)

    Automattic Happiness Engineer

    Hi Millie,

    Thanks for the feedback. I’m sorry to hear that you’re having troubles.

    I don’t know why the 404 error might be happening, but if you could provide a link to where the survey in question is, I would be happy to take a look and try to help you out.

    No problem thanks for getting back to me so quickly

    Here is the post
    http://fortheloveoflingerie.com/insiders/

    Please let me know if it’s fixable as soon as you can so I can come up with an alternative solution if not.

    Thanks again Will 🙂

    Plugin Author Will Brubaker

    (@willthewebmechanic)

    Automattic Happiness Engineer

    The 404 is being caused because the javascript for Awesome Surveys is not being loaded, so the survey is not being submitted via AJAX. My best guess is that W3 total cache is blocking/removing the necessary javascript.

    To verify, can you do this?

    under the W3 Total Cache menu:
    Performance > General Settings > Minify
    Uncheck the ‘Enable’ checkbox & press ‘Save All Settings’

    Let me know when that is done and I’ll take another look at your site.

    No problem, I unchecked the enabled JS minify setting checkbox. Did you need the CSS disabled as well or just the above.

    Thanks again .

    Plugin Author Will Brubaker

    (@willthewebmechanic)

    Automattic Happiness Engineer

    I’m not sure that’s the right checkbox.

    Here’s a link to a screenshot of what needs to be disabled:
    http://willthewebmechanic.com/w3-settings.png

    Oh I’m currently using wordpress.org however I’ve taken screenshots, maybe that will be of more help.
    http://www.screencast.com/t/5hsxAYvV5n
    http://www.screencast.com/t/VjBBimsNJc
    http://www.screencast.com/t/Jis4XIIKF
    http://www.screencast.com/t/K7rhay7sb
    http://www.screencast.com/t/K5FrJkEYZ01h

    Let me know how you go, and again, thankyou for your help. 🙂

    Plugin Author Will Brubaker

    (@willthewebmechanic)

    Automattic Happiness Engineer

    The settings in my provided screenshot can be accessed under:

    Performance > General Settings

    Sweet, found. It seems to be already unchecked. Is there anything else I could try?

    Plugin Author Will Brubaker

    (@willthewebmechanic)

    Automattic Happiness Engineer

    On the same ‘General Settings’ screen can you find the ‘Debug’ box and, if you are able to check the checkbox for ‘Minify’ do that, and again ‘Save All Settings’

    I am unable to check the minify box

    Plugin Author Will Brubaker

    (@willthewebmechanic)

    Automattic Happiness Engineer

    What other plugins do you have installed that might be altering the loading of javascript?

    Sorry about this (I am still working everything out) I am unsure as to which could be interfering however these are what I have installed at the moment

    Askimet
    Async JS and CSS
    BWP Google XML Sitemaps
    Contact Form
    Digg digg
    Disqus Comment System
    Easy Custom Auto Excerpt
    Google Analytics Dashboard for WP
    MailChimp for WordPress Lite
    NextScripts: Social Networks Auto-Poster
    OptinMonster
    Shareaholic | share buttons, analytics, related content
    Subscribe / Connect / Follow Widget
    Swiftype Search
    TPC Memory Usage (Updated)

    Use Google Libraries
    W3 Total Cache
    WordPress SEO
    WordPress to Buffer
    WP Missed Schedule

    I’m not sure if that will be of help or not?

    Plugin Author Will Brubaker

    (@willthewebmechanic)

    Automattic Happiness Engineer

    can you de-activate Async JS and CSS temporarily?

    Sure. It should be disabled now and I’ve cleared the cache.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘404 Error when submitting’ is closed to new replies.