Support » Fixing WordPress » 404 error when accessing pages

  • Hello,

    I get 404’s when I try and browse to my pages. If I set permalinks back to ‘plain’ I can see my pages, but I cannot access my json endpoints.

    How can I fix it?

    Here is my .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Here is my .conf, located in /etc/apache2/sites-available

    <VirtualHost *:80>
       ServerName xxx.xxx.co.uk
       DocumentRoot /var/www/xxx.xxx.co.uk
       <Directory /var/www/xxx.xxx.co.uk/>
          Options Indexes FollowSymLinks MultiViews
          AllowOverride None
          Order allow,deny
          Allow from all
       </Directory>
       ErrorLog /var/log/apache2/error.log
       CustomLog /var/log/apache2/access.log combined
    </VirtualHost>
    • This topic was modified 1 month, 2 weeks ago by  matthisco.
    • This topic was modified 1 month, 2 weeks ago by  matthisco.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Hi, matthisco, & welcome. Try putting a # in front of this line so that it looks like:
    #AllowOverride None
    & see if that doesn’t help. Please let us know, ok?

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.