Support » Plugin: WPS Hide Login » 404 error sometimes for wp-admin and the login url (caching?)

  • Dimono

    (@dimono)


    Hi there,

    I have some problems logging in using Chrome (both mobile and pc). When I use the created login link I get a 404 error and when I am logged in (the account page of woocommerce) wp-admin stil gives a 404. I have to visit another page then admin to get access to my admin menu (dashboard does not work).

    For my client this workaround is not ideal. How can this be solved?

    It looks like a caching problem that occurs on chrome after using the site a while. Clearing cache only works for a short while. I am not using any caching plugins.

    How can this be solved?

Viewing 8 replies - 1 through 8 (of 8 total)
  • chadrebs

    (@chadrebs)

    I’m experiencing exactly the same issue as @dimono.

    claybrooks

    (@claybrooks)

    I am experiencing the same issue.
    I installed the plugin, defined the URL and now it is broke.

    Any idea?

    Not sure if it’s exactly the same but if I try to access the wp-login or wp-admin page I get error 404, even when I’ve set the redirection url to my about page. Tried on 2 sites with pc and mobile.

    Getting the same error.. I noticed that when you create your link it is not placing the / in between your domain and your new name. example:

    https://abc.comnewlogon/ instead of https://abc.com/newlogon/

    I’ve installed in 3 different sites thinking it might have been a corrupted dowwnload but it does the same thing on all.

    Hi t1pservices, check the created link? I don’t think that’s the same as my problem.

    Its like the url’s are being cached wrongly. When using another system, browser or the incognito tab, this problem does not happen.

    I started uninstalling the plugin on some sites. Because clients that regularly need to login, cannot login anymore. This problem is unsolved for some time now so sadly I’m going to have to look for alternatives.

    I’m also experiencing this issue. My login URL is showing up as a disk cached 302 redirect to wp-admin, which is redirected to a 404 error. If I disable the cache in my browser it works fine, and then once I clear the cache on my wordpress install it works fine for a little bit. I’ve set up my cache plugin to not cache my login page (cache enabler), it doesn’t seem to be doing any good though.

    The cache control header shows up as “no-transform, no-cache, must-revalidate, max-age=0” when I manage to actually get to my custom login page.

    When I get the redirect it shows up as “private, must-revalidate”. I’ve even tried using rewrite rules on my server to force the 302 redirect to not be cached to no avail.

    At this point I’m out of ideas.

    Plugin Author NicolasKulka

    (@nicolaskulka)

    Refresh permalinks, permalinks ‘%post_name%’, download last version ?

    An update:

    I ended up having to switch to a different plugin. I tried really, really hard and for way too long to get this one to work properly. Still no clue what was causing the issue, other than some vague “caching issue”.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.