Support » Fixing WordPress » 404 error publishing post with HTML

  • I’m receiving 404 while trying to publish posts with html. Normal post with no html hyperlink or basic html gets published but when ever i try to post with basic html like hyperlink or image it gets 404!

    I tried deactivating all plugins and using default theme but no luck.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Same here. I tried to add a picture and after updating the page, I get a 404 error? There’s no broken links, so what could be the problem?

    I don’t know, the error is really strange. I found few other facing similar 404 error.
    I’m pretty sure it is not cause of plugins or theme as i have tried with 0 plugins and default theme.
    Memory limit is also enough i.e 384Mb.
    I’m not sure if host/server can be suspected.

    Could it be a bug??

    I just have the same issue today :S didnt happen before, have not installed any plugins since it last worked.

    Who is your hosting provider?

    Just tried setting permalinks to something other than %postname% and now i’m getting forbidden message.

    Sorry for multiple posts

    I solved this by contacting my hosting provider, it was a rule that had been triggered in ModSecurity that caused all html to be blocked in new/edited posts.

    I’m with namecheap and they solved the issue in 2 minutes.

    I’m too on namecheap!
    I will try contacting them.

    Have you been using WP Security Plugin ?

    • This reply was modified 1 year, 3 months ago by  pri2sh.

    No

    They could not tell me what caused the rule to trigger, but typically it was due to installation of new plugins that caused a false-positive thinking it was being attacked while so many files were changed.

    I also need a solution to this problem…

    I am having the same issue. I first noticed it when trying to publish an image, but then I saw it’s for any type of code.

    I have this exact problem! I can post a plain text post but as soon as I try to post something with an image, it will direct me to a 404 error(luckily the post saves as a draft)
    When I went to my host, HostPapa, they stated that they did disable ModSecurity and since that isn’t working they need my wp-admin credentials to try and replicate the issue…. this implies they want to post to my blog.
    This is weird right? I have refused to provide my username and password to my blog but they have insisted again they need to replicate the issue. Am I right in refusing this? Is it actually that sketchy?
    This is a brand new blog without any posts or followers so it technically wouldnt matter all the much for them to post (i could always change passwords after).. I’m refusing on principle but here asking if maybe I am wrong?

    Kaari, of course give them your details. How else will they fix it?
    Change your password in WP admin, give it them and change it back later.

    bodywise

    (@bodywise)

    So many people with the same problem. So few answers. All the answers on line do not solve the problem. So this must be a known bug in WP that no one is willing to admit.

    It is maddening. You know the pages are there. They just don’t show up. I have tried all sorts of owner and permission settings. The usual htaccess rewrites. Nothing works.

    All you need to do is to disable ModSecurity. If you have cPanel you can find it there, if not or if it’s not available, speak with your hosting company about this.
    Remember: if you have multiple domains, disable ModSecurity only for the domain with the issue, don’t disable for all of them since it can be quite useful for all of your other projects.

    Cheers!

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.